Just above the Swype keyboard there is a word choice list bar.

How do I disable this feature?

Peter