+ Reply to Thread
Results 1 to 4 of 4

Thread: Swype 3.0 likes to autocapitalize 'I' in the middle of a word

  1. #1
    Join Date
    Jun 2011
    Posts
    2

    Swype 3.0 likes to autocapitalize 'I' in the middle of a word

    Device Make/Model: HTC Thunderbolt
    Wireless Carrier: Verizon
    Android Version: Gingerbread 2.3.4
    ROM Version: Custom ROM http://forum.xda-developers.com/show....php?t=1087617

    Are you a ROOT user? Yes

    Steps to reproduce:

    1)Get the android terminal emulator: http://www.appbrain.com/app/android-...al.androidterm

    2) Open it up and with swype, type something like (by typing, not swyping):
    ping google.com

    It will "auto correct" the above to pIng no matter how many times you try to go back and undo it. This is mostly annoying for terminal commands that are obviously not going to be in the dictionary.

  2. #2
    Device Make/Model: lg vm670 optimus v
    Wireless Carrier: Virgin mobile
    Android Version: Gingerbread 2.3.4
    ROM Version: Custom ROM aospCmodOV

    Are you a ROOT user? Yes

    Steps to reproduce
    1)Get SL4A from google code android-scripting (devs say the terminal is based on ConnectBot)
    2) open a shell terminal
    3) with swype, type something like (by typing, not swyping):
    ping google.com

    It will "auto correct" the above to pIng no matter how many times you try to go back and undo it. This is mostly annoying for terminal commands that are obviously not going to be in the dictionary.

  3. #3
    Join Date
    Jul 2010
    Posts
    1,189
    We discovered this issue ourselves just a few days after launching the latest beta. The issue relates to how we handle the special field_type=NULL scenario which terminals use. It's inadvertently causing our predictive tap engine to treat each character typed as its own "prediction" and since we have Swype set up to always auto-capitalize the letter "i" in English, it does just that :P We've added a bug to our internal issue tracker and will be looking at suppressing auto-capitalization of the "i" character for field_type=NULL.

    Sorry for the inconvenience and thanks for the bug reports! If you'd like, you can probably work around this bug by switching to another language that doesn't auto-caps 'i' such as Spanish or German. Hope that helps!

  4. #4
    I've been working around the issue by manually entering each command with an 'i' in it to the dictionary (in a text editor app seperate from the terminal) as they glitch, so I can swype them instead of fumbling with single-key entry.
    might as well, if I liked to peck at the keyboard I'd be using one with a CTRL key anyway!
    thanks for the response and suggestion.
    Last edited by bigsupersquid; 06-18-2011 at 11:37 PM. Reason: fix typos

+ Reply to Thread

Similar Threads

  1. Replies: 0
    Last Post: 06-15-2011, 6:01 PM
  2. ENGLISH - US Android: Disabling autocapitalize for certain <input type="text">
    By mdhari in forum English Language Development
    Replies: 0
    Last Post: 05-06-2011, 1:19 PM
  3. Replies: 0
    Last Post: 03-16-2011, 2:28 PM
  4. Feature Request: Option to delete word that is hiding the word you type
    By pmaxwell in forum Android Feature Requests
    Replies: 0
    Last Post: 09-20-2010, 2:52 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts