PDA

View Full Version : KNOWN BETA for Android ISSUES - Please read before posting (UPDATE: 12/7/10)



brian.resnik
08-18-2010, 8:31 PM
<div style="font-size: 24px; font-weight: bold;">This article has been superseded by the new KNOWN ISSUES category. Please <a href="http://forum.swype.com/forumdisplay.php?61-BETA-Known-Errors-Read-Me-First">CLICK HERE</a> to go there now</div>

<div style="text-decoration: line-through;"><div style="text-align: center;"><div style="color: #FF0; font-size: 32px; text-transform: uppercase;">known Swype BETA for Android issues</div><div style="color: #F00; font-size: 18px;">This thread contains information on problems known to exist with the <u>Swype Beta for Android</u> and any known workarounds for them. Please read this thread carefully, as posts which are answered here may be <b>DELETED</b> without warning.</div></div>
<p style="font-style: italic;">Part of the purpose of this thread is to give Beta for Android users a basic primer on what causes some of the most common installation and operation problems. Many times, users will find that their issue is unique in its specific causes, but can be traced back to a common cause (such as low-memory). The goal of this thread is to allow our users to effectively troubleshoot problems themselves and with the help of others in the community. When troubleshooting, remember that this is beta-level software and as such certain elements may not function properly.<br /><br /></p><div style="font-size: 24px; color: #06F; text-decoration: underline;><p><span style="text-transform: uppercase;">Section 1:</span> Issues with no known solution</p></div><p><span style="font-weight: bold; text-decoration: underline; color: #1c7515">On the Droid Incredible, swyping produces a blue border, error sound, and no text, immediately after rebooting</span><br />The Droid Incredible is, apparently, trying to load the Swype application before the ESN system variable has been populated. When Swype tries to load the license, it cannot match the ESN, and fails. Reloading the app by long-pressing a text input box, choosing "Input Method" and selecting Swype will resolve this issue for you until your next reboot.<p><span style="font-weight: bold; text-decoration: underline; color: #1c7515">Error: "Download of the package failed. Swype is already installed. Please uninstall Swype and try again."</span><br />This is occurring on older devices, or heavily customized ROMs, when the system becomes dangerously low on resources, and kills the SwypeInstaller front-end (along with many other apps on the system), while the installer service itself continues to run, and the license is never installed. When the service is resumed (after finishing Swype package installation) it reloads the front-end which doesn't recognize the active state of the installation, and starts over, checking if Swype is installed. This will be addressed in an installer update soon.<a name="PossibleSolution"></a><p>This error will also occur if the developer of your ROM has failed to remove the file /system/lib/libSwypeCore.so.
<div style="font-size: 24px; color: #06F; text-decoration: underline;"><p><span style="text-transform: uppercase;">Section 2:</span> Issues with known workarounds</p></div><span style="font-weight: bold; text-decoration: underline; color: #1c7515">ERROR: Swype is configured for another device and will operate with limited functionality</span>
This error indicates that there is a problem with the Swype registration files on your device. First, make sure you've followed the Basic Troubleshooting Steps (http://forum.swype.com/showthread.php?994-HOW-TO-Get-BETA-for-Android-troubleshooting-help). Then, try the following:

If you've recently upgraded your system software you will need to reinstall Swype. You can request a new email containing the Swype Beta download link by logging into http://beta.swype.com and clicking the "Resend Activation Email" link in the lower right.
If your first installation attempt fails, you can use the installers built-in repair functionality to get up and running. Simply run the Swype Installer a second time and it will guide you through the steps of repairing your license.
If none of the above solutions work for you, please make a post in the existing "Swype is configured for another device" thread.


<a name="cleardata"></a><span style="font-weight: bold; text-decoration: underline; color: #1c7515">BUG: After using the "Clear Data" function in Android 2.1 and later to set Swype back to default settings, running the installer to generate a new license fails.</span>
This is an issue with how the Swype APK handles generating the license when the data directory has just been recreated. Simply run the SwypeInstaller again and repeat the repair process. Everything will work as planned.

<span style="font-weight: bold; text-decoration: underline; color: #1c7515">BUG: Some SenseUI enabled devices lose MULTITOUCH functionality after Swype is installed.</span>
This issue should be resolved if you reboot your device. If this is NOT the case, please submit a trouble-ticket (http://forum.swype.com/support.php).

<span style="font-weight: bold; text-decoration: underline; color: #1c7515">ERROR: This device is already associated with another account..."</span>
It is likely that your device's ESN number improperly associated with another account, either as a result of an error in our system, or because you're using a refurbished replacement device whose previous owner had Swype BETA installed. Please read the first post in this thread for more information: this thread (http://forum.swype.com/showthread.php?1048)</div>

herotness
09-14-2010, 2:10 PM
I was having this problem prior to updating to September beta version...when I try swyping a word I get a protest beep and no word appears. I can individually touch letters and it works OK.

When I uninstalled older version (and was having that problem then) and reinstalled the new beta Swype was working fine but suddenly stopped working today.

I've tried rebooting phone but does not fix.

I just uninstalled advanced task killer to see if that was a problem.

I've removed and reinserted the battery to see if that helps.

Yes, it fixed the problem. Not sure which of these, but suspect advanced task killer.

filidhruadh
09-15-2010, 8:54 AM
SWYPE IS NOT WORKING with update Beta, on HTC Desire

I'm experiencing exactly the same problem - no word appears when I swype but individual letters work ok. I had the problem with the previous version, when I installed the new one it worked perfectly for one day, then stopped...
Ok just now, after rebooting... till the next time!
Pity, I'm hooked on it, and hate being without it....

whitehou
09-15-2010, 10:50 AM
Motorola Droid 1
Verizon
FroYo 2.2 with second update
Stock ROM
Not a Root User
Swype Version 2.4.44.10912

Since the Swype update (installed yesterday), I have not been able to use Swype. I receive the blue border flash and the error beep when trying to swype text.
I followed the uninstall instructions exactly.
After reinstalling and the report that it was done, I received the message that Swype was already installed.

rljoyette
09-17-2010, 8:22 AM
Hi
I have been having problems installing swype. It gives me "your phone id doesn't match registration. I have tried everything that was
stated on the swype forum, it's still not working. Is there anything you can do? Swype is the best keyboard ever. After using swype I
can't go back to using a regular keyboard. Can you help me?!!
Thanks

Id of your phone doesn't match registration
Device Make/Model: sony X10a
Wireless Carrier: rogers
Android Version: 1.6
ROM Version: Stock
Are you using APPS2SD? No
Full text of the error message: the id of this phone does not match your registration at beta.swype.com
What troubleshooting have you completed so far? I Tried to remove and reinstall. Searched the forums.
Are you a ROOT user? No
http://pastebin.com/5Z0WQpSH ----swype info located around 610 and beyond on the sendlog

thoughtbox
09-20-2010, 12:31 AM
FYI, the update does not work correctly on my HTC Hero -- whenever I Swype a word, I get a blue border "flash", and but no word (or word suggestions).

adb logcat shows the following when booting, and there are no other error messages when this (the blue flash/keyboard not responding to swypes) occurs.

I/PackageParser( 158): com.swype.android.installer: compat added android.permission.WRITE_EXTERNAL_STORAGE
W/PackageManager( 158): Not granting permission android.permission.INSTALL_PACKAGES to package com.swype.android.installer (protectionLevel=3 flags=0x7e44)
I/InputManagerService( 158): Enabled input methods: com.swype.android.inputmethod/.SwypeInputMethod:com.google.android.voicesearch/.LatinIMEWithVoice:com.htc.android.htcime/.HTCIMEService
I/ActivityManager( 158): Start proc com.swype.android.inputmethod for service com.swype.android.inputmethod/.SwypeInputMethod: pid=232 uid=10061 gids={}
D/dalvikvm( 232): Trying to load lib /data/data/com.swype.android.inputmethod/lib/libSwypeCore.so 0x44e9fb98
D/dalvikvm( 232): Added shared lib /data/data/com.swype.android.inputmethod/lib/libSwypeCore.so 0x44e9fb98
E/Swype ( 232): Could not open license from the APK: files/license.dat
I/Swype ( 232): Swype version: [2.4.44.10912.t100]
D/Swype ( 232): Swype initialized.
D/Swype ( 232): SwypeDataInitializer.onReceive

The "Languages" option in the configuration menu for Swype is greyed out too.

/TB

davidjmorin
09-22-2010, 6:50 AM
For people with issues where you just get the blue border and nothing types. This is what I did
1. Uninstalled task killers
2. uninstall swype
3. download swype
4. install
5. test and work

amorris676
09-22-2010, 12:37 PM
I have also come across the problem where swyping a word doesn't work, but I can tap to type. I found that if I long press the text field and change my input method to the stock keyboard, then do the same thing and change right back to Swype, it will then work. No reboot needed. Still annoying, though.

HTC EVO 4G, rooted
Fresh 3.2 ROM

Dr.Carlos Alayon
09-22-2010, 3:12 PM
I change My Nexus One and Buy a Dell Streak and last week I try to install the Sept. Update first time in the Streak but everytime I run the installer I have this message "Enter the user name and password you registered at beta.swype.com." I try and try but can't login.:( Please some one can point me in the correct direction :(

Device: Dell Streak
OS: 1.6 Rooted