PDA

View Full Version : Bug report - Swype causes IME to hang/crash



migr8759355
03-16-2010, 7:37 PM
I was experiencing the Swype beta periodically freezing on my Moto Droid, randomly I thought at first, but then I discovered the pattern. When I manually key in a word that I know Swype will not recognize, the keyboard hangs (I'm just assuming it's trying to add the word to the dictionary and hangs at that point). To clear things, I have to switch the input method back to android, and then back to Swype again, but the entire input method process hangs for many seconds before it once again allows me to type any characters, even on the android keyboard.

The "leaked" preview didn't have this problem, it ran flawlessly for almost two months. This bug is making the beta very difficult to use.

migr9092821
03-18-2010, 6:39 PM
I have been experiencing the same bug. It seems to be happening more regularly the more I use it. Moto Droid.

GirLuvsDroid
03-19-2010, 10:09 AM
The same is happening to me and it's getting worse every day on my Moto Droid. Now, even switching between keyboards isn't always working and I'm getting more and more force closes with Swype. It's crippling the other keyboard, as well, until I get the force close message for Swype.

I've also maxed out on my Swype downloads, so I can't even try downloading a clean version to see if it will help. I feel completely crippled without Swype -- please fix this!!

migr1586866
03-21-2010, 5:08 PM
Hey everyone,
So sorry to hear you are experiencing this problem. I just wanted to let you know that we are now aware of it and I am asking the engineers and Q/A manager about this issue. Thank you for your feedback and support!

migr8725239
03-22-2010, 11:25 PM
Same here. I had the pre-beta release, then signed-up here and downloaded the beta. The initial fix of switching input keyboards helped at first, but now it has just started to exhibit the same behavior as above. However I can't attribute it to trying to memorize words, it happens all the time. Sometimes switching input methods fixes it, now more often than not it doesn't. I just tried reinstalling again, and still same behavior. Motorola Droid here too.

migr1547470
03-22-2010, 11:51 PM
I suspect that you all have Predictive Text turned on in your options. For now, you can disable that and this bug should go away. We already have a fix internally that we are testing and will be in our next beta refresh.

migr8759355
03-23-2010, 7:26 PM
This suddenly got worse today, and even rebooting doesn't get swype working correctly - my swype seems completely hung. I'll try re-installing it later when I have time, but I hope I don't run up against whatever download limit people have been talking about.

migr9224477
03-25-2010, 2:28 PM
Yep, same problem here on a Moto Droid. Seems whenever I press to spell words or long press a character to add a number it happens. Predictive text is off and has never been on. Getting more and more frequent. Please help me from having to use stock keyboard.....

migr8759355
03-25-2010, 9:07 PM
I checked, and word prediction is turned off, so I presume it has been turned off the whole time, yet the bug has been occurring.

RichSmithSWM
04-20-2010, 9:49 AM
I don't know if this is related. Everything was fine with the Swype beta on my Droid until I installed Google Gesture last week. Almost immediately after the install Swype would hang for 30 or more seconds every time I tried to send a text message. Once it hangs even the Android keyboard is hung. I don't know if this is a problem with Swype, Google Gesture or it's just a coincidence. I uninstalled Google Gesture but the problem remains. I haven't done a factory reset yet to see if this clears up the problem. Figured I mention this though.

brian.resnik
05-16-2010, 6:36 PM
Can you get in touch with me directly, either on irc.freenode.net in channel #swype, or by emailing me at brian.resnik@swypeinc.com? I'd like to guide you through some debugging steps to help us track down the source of this issue. Thanks!

dggopal
05-17-2010, 5:44 AM
tried going on IRC today because I didn't hear back from you... I am currently in India so I assume the time difference is an issue as there were only 5 people in the channel at the time... sorta new to IRC so I may have not been in the correct channel... but it said something about being the unofficial channel for swype... anyways let me know what a good time is for you to chat on IRC regarding this problem...

brian.resnik
05-17-2010, 2:47 PM
Yeah, it looks from the logs that you were in there at about 4:30am EST, which puts me soundly in bed at the time :)

I've emailed you back with some instructions. You can stop by the IRC channel any time between 11am EST and 1am EST and I'm usually available (I'm the only admin in there). Otherwise, just get back to me via email and we can do it that way.

migr10431820
05-17-2010, 10:36 PM
Having the same issue on my Motorola Droid.

migr11058696
05-21-2010, 9:11 PM
05/21/10: If it helps any, I am facing this same issue. However, it has only started happening within the past few days. Pre-beta worked flawlessly and I have been using since early March with heavy text usage.

Not sure if it's related, but I actually just looked into the add/delete words from dictionary feature. I know Swype automatically adds for new pecked words but when I looked into the the dictionary feature there was nothing listed there - even though there are LOTS of words in the dictionary (we have a lot of asian and hawaiian words here).

migr11968043
05-30-2010, 2:46 PM
Swype is completely unusable for me. This bug persists even after switching back and forth or turning any settings on or off. I see it's been 2 weeks since the response team has posted and a couple months since it's been classified an issue, are there any new updates to this issue? Id love to help if it means it would further this along. =)

brian.resnik
05-31-2010, 10:07 PM
I've passed this along to our QA team. Additionally, we have an update coming to the beta soon that may fix this issue. I'll keep you updated as I hear more. Sorry I can't be more help at the moment. Things are super busy around the Swype HQ lately!

migr13483655
07-28-2010, 11:54 PM
I ran swype beautifully for about a month+ now it is unusable... I have uninstalled & re-installed with no luck...

my phone (HTC Hero [cdma]) hangs for minutes rather than seconds - started about 2 days ago... wiped phone thinking it was a recently added app - apparently not...

looking forward to hearing about a fix - love the keyboard when it works... good thing the graffiti app has recently come out...

Thanks

migr13570589
07-30-2010, 11:52 AM
I ran Swype on my Droid for about a month, and besides having swype freeze, suddenly I'd find all my screen icons gone. I could only get them back by rebooting, which is annoying. I finally narrowed it down to swype - If I disable it in Settings, the phone is fine; if I leave it enabled, I'll lose the icons 2 or 3 times a day. I love swype when it works, but this is a bug I can't put up with. Anybody else experience this?

migr8725239
07-30-2010, 12:38 PM
I've noticed my icons disappearing a few times, just thought that the home application stopped running. I wasn't able to attribute it to Swype though. It's a sporadic thing.

RoryH
08-20-2010, 6:26 AM
Also experiencing this problem, I think I only noticed it when I updated Swype after upgrading Android to 2.2

momo the monster
08-23-2010, 1:03 AM
Serious freezes with Swype using 2.2 on Droid Inc. Uninstalled for now. I miss it so much!

brian.resnik
08-31-2010, 10:53 PM
I'd like to start compiling a group of logs for comparison, so the more people who can post their logs by following these directions (http://forum.swype.com/showthread.php?994-READ-ME-FIRST-HOW-TO-Get-BETA-for-Android-troubleshooting-help#LOGCAT) the better. Post 'em up, people!