PDA

View Full Version : Swype Not Working Correctly on Nexus S after Android 2.3.3 Update



badgerdog
02-24-2011, 5:00 PM
After Swyping a sentence, when I double tap on a word to correct, the Android "Cut/Copy/Paste" menu pops up in front of the word choice window. If I press the back button to close that window, I cannot select words from the word choice window. The keyboard flashes blue.

Also, when I tap in the text box to bring up the keyboard, the text edit arrow pops up, blocking the "Q" key.

henriquesp
02-25-2011, 4:13 AM
Did you remove the Swype app (not the installer) and reexecuted the installer?
You'll always need to do that after an OS update.

badgerdog
02-25-2011, 5:45 AM
Thank you for the suggestion, but I have already performed the reinstall.

brian.resnik
02-25-2011, 6:11 AM
This is a known incompatibility with Gingerbread, unfortunately. The current beta does not include our Gingerbread fixes yet. We'll be releasing an update soon (days/weeks not months), so keep your eyes peeled for that, which may resolve some of the gingerbread related issues.

badgerdog
02-25-2011, 8:43 AM
Thanks Brian. I was aware of some minor gingerbread annoyances, but 2.3.3 has rendered Swype unusable for now.

jvmatl
02-25-2011, 7:14 PM
I want to second what badgerdog said: this is not a "Gingerbread" (2.3) problem, it is a brand new 2.3.3 problem introduced with yesterdays update. Previously (two days ago, with 2.3.2 or 2.3.1,) if you double-tapped on a word, it would highlight and you would get the swype correction list. In order to see the android "edit text" menu, you used to have to long-press on the highlighted word. Now there's no delay between highlighting the word and the appearance of the edit text menu, which prevents you from interacting with the swype correction list. Personally, it looks like an Android regression to me, because the text widget its now flaky in other hard-to-describe ways, too-- but the fact remains that as-is, it is nearly impossible to correct text entry errors in swype, when this worked perfectly for me two days ago, on my Nexus S running Gingerbread pre-2.3.3.

Thanks for your time.

jvmatl
02-25-2011, 7:54 PM
When the cut/copy/paste menu comes up, hit the back button, then try to select a word from the correction list. IF you get the blue keyboard flash, hit the swype button and then try the word chooser again. This works for me to unlock the word chooser and let me correct text, but there is still some oddball stateful behavior I haven't figured out yet, because I usually only need to hit the swype button once per text input field.

IronSingh
02-27-2011, 12:21 AM
I removed Swype and Reinstalled it got a prompt new installer available.

working without any problems now.

The Cut/Copy Problem exists but I always used the swype button so no biggy.

Peace.
IronSingh

gideon
03-02-2011, 11:39 AM
and now it works fine again. Thanks for the help.

Did NOT uninstall installer, just the app.

brian.resnik
03-08-2011, 6:47 AM
Unfortunately our research into the issue hasn't gotten us very far. It appears that the changes implemented by Google can't be suppressed. That is to say, there is no way for us to programmatically intercept the double-tap event and prevent the Android cut/copy/paste window from showing up. Individual application developers can do this, but the input method doesn't have the ability to stop it. We're still looking into alternative solutions, but for now there seems to be nothing we can do.

Fortunately this issue is only present in Android 2.3.3. We've even tested it on Honeycomb and the handling is completely different so it's not a problem there.

If you know any Google developers on the Android team, feel free to poke them on our behalf about this problem.

This issue is being covered on our Bug Report forums. You can keep up to date with the developments in this thread: Double Tap brings up Android "Edit Text" menu instead of Swype word menu after update