PDA

View Full Version : Installing swype on HTC Inspire



bmunger
02-19-2011, 7:44 AM
I'm new to the droid family. I just got the HTC Inspire and I'm trying to install swype on it. The problem I'm having is I downloaded the installer,it went into the file manager astro that I got from the market. In the Astro program I select sdcard, then download, then I select any one of the 3 swype installer downloads I have because I thought I was doing something wrong so I downloaded the installer 3 times. So I select one and hit open app manager, then install, then it tells me for security you phone is set to block apps that aren't optained from the market. So I select settings like the instructions say to do. But then I'm not given the option to select unknown sources like the instruction say. The only options I'm Given are manage applications, running services, development, and fast boot. I looked through all these and see nothing that has to do with swype. I guess at this point I would like to remove the 3 installer downloads that I have And start all over with some help

rob.boehm
02-20-2011, 1:02 AM
Please check this thread on installing non market apps on ATT devices.

.//edit
Whoops, forgot link: http://forum.swype.com/showthread.php?2288-Phone-set-to-block-installation-of-apps-not-in-Android-market-ATT-Devices

sam8940
02-23-2011, 3:27 PM
Google android central sideload wonder machine

rhousedorf
02-26-2011, 9:04 PM
Robert, I'm sorry, but I don't see a link.
Using chrome.

Also, sideload wonder machine does not work. You can install the Installer, but when you run the installer, you get the same android error message. I'm currently trying to figure out where the installer downloads the .apk of swype itself to, so I can use sideload wonder machine to install it.

rhousedorf
02-26-2011, 9:18 PM
This is the link
http://forum.swype.com/showthread.php?2288-Phone-set-to-block-installation-of-apps-not-in-Android-market-ATT-Devices

rhousedorf
02-26-2011, 10:54 PM
OK, full instructions from a stock Inspire phone, for windows, NO ROOT:
As is usual, you are responsible if you screw anything up.

Note:
This is basically what I did, although I didn't generate the key and screwed everything up on my Inspire for a good 5 minutes.
Tomorrow, I'll try it again on my wife's inspire, ( assuming she lets me of course... ), and rewrite this process in a new post, but this should get people working.

FYI, for my phone, this did NOT stick after a reboot, even with fastboot unchecked!
EVERY time I reboot, I have to run the swype installer, then change to normal keyboard, change back to swype keyboard, from a long press in an input field
( Yo, Swype, I'm volunteering to factory reset my phone and test for ya, once I figure out how to save my Multicon setup... Email me if you like. )

Note that I turned OFF the fastboot option under:
Settings, Applications
<sarcasm> Yeah, this slows down boot by a good 10 or 12 seconds.... </sarcasm>
Not sure if needed, but there was a post someplace on the swype forums that mentioned turning it off.

Read ALL of these instructions first, and assemble/download/install the proper software.
Also, READ what shows on your phone, and on your PC!


Pay attention to where you install stuff! Most problems can be resolved by opening windows file explorer and just looking at the subdirectories and seeing where you installed things.

Read ALL THE BELOW BEFORE PROCEEDING. There are alternate methods of doing some of the actions!

Just in case you missed it, Read **ALL** THE BELOW BEFORE PROCEEDING! It's late, and I'm not that coherent at 2:30 am.... Heck, I'm not that coherent at noon...


Follow http://www.attdroids.com/forum/android-apps/612-app-swype-1-25-16-5612-a-3.html#post6070
Yes, it's for a backflip, but the instructions work, if you PAY ATTENTION and think about what you are doing.
Also, if you can't follow the line:
- install the Swype Installer via adb install command ("adb install Swype-Installer.apk")
then go to
http://forum.xda-developers.com/showthread.php?t=943174
And follow those instructions to the letter.
This will get you a running adb and a way to install the installer using Sideload Wonder Machine.
You'll need to get Swype-Installer.apk off your phone by connecting your phone as a USB drive.
The apk will be in the download directory of the sdcard.
"download" should be right in the mapped drive letter of the phone. ( Settings, Connect to PC )

There are two parts to the install. Install the installer, then install swype.
( It's probably useless to ask why there is a two part install, but there is probably a good reason. I can't think of one, but I love swype so damn much, I don't really care. Yes Swype, would you please throw some damn dev resources at this so I can send you money? I'll pay $10 US for swype if I have to. That's how much I love it... )

So, you have the installer installed. Run it.
Back to the www.attdroids.com link, above, start at step:
- click "Start Download" button. This step is on the phone.
and follow those. You CANNOT get the swype program itself by copying from the SD card. ( Well, I couldn't find it. )

NOTE: After the install commands at the dos prompt, I did not get the usual android security install warnings. It just installed.

Now, MOST IMPORTANT. DON'T try to use swype yet!!!!!!!!!

Run the installer again, login, whatever shows for you.
Cancel out of the error message if it shows for you.
Use Advanced Task Killer or something to close it. Whatever...
At this point, I had issues.
You basically have to run the installer again, login again, and it generates a key.

Once the key is generated,
Open Settings, Language and Keyboard.
Enable Swype. Set Swype settings if you like now, or later.
Home, Applications, Messages.
Compose message.

Long press in the "Tap to add text" field, choose Input method.
Select swype.


Once done, you should have:
Swype-Installer.apk
mypackage.apk
AndroidCentral-SWM.exe ( plus several other files )
HTC Sync setup_3.0.5511.exe ( run this install early on. yeah, you MUST reboot. It installs drivers.
Be sure to EXIT the HTC sync app, or ADB commands will not work.)
on your pc.

Read on if you have issues.
Basically, I lost my normal keyboard. Spend a few minutes cleaning out your pants, then proceed below:

Reboot phone first.
Once rebooted, make sure swype is still selected in Language and Keyboard.
Go to apps, messages, compose.
long input.
Select swype.
try long input and select standard keyboard. if it does not work, go back to swype keyboard.
Now go run the swype installer again.
login. Let it do it's thing. Press the common sense choices. I forget what the heck I did, but it was really obvious.
Back to messages, compose.
long press.
switch input methods.
Both should now function correctly.
Normal Keyboard works after a reboot, but Swype doesn't until I reactivate it.

"Post Quick Reply" doesn't seem to fit after this freakin book, but there you go...

Wei-min Lee
03-18-2011, 1:32 PM
I first experience swype on my Atrix and just loved it so when I got the Inspire for my wife, I was stumped as why I couldn't enable the swype keyboard. I'm new to Android so I didn't know it wasn't installed by default or wasn't available on the Market. My search lead to many discussions for sideloading apps and I decided just going with the core tools necessary - no wonder machine or anything packaged to just do stuff behind the scenes. Finally with the help of all the information I found the combination of 2 postings lead to success...

The post in the attdroids forum was helpful, but ultimately following this posting on androidcentral, http://forum.androidcentral.com/htc-inspire-4g/60295-guide-installing-swype-beta-htc-inspire-4g.html, is how I completed the install on my Inpsire - pain free.

From the attdroids poisting, it wasn't immediately clear to me that there was a Swype Installer icon in my list of apps, that's where the androidcentral forum helped me get further. Also, I tried looking for the mypackage.apk on my PC to try to confirm the pull and couldn't find it anywhere. This didn't stop me from being able to issue the install command against mypackage.apk.

My install was accomplished only with the Android SDK, Java JDK, and of course had to make sure my device sync software was first installed (needed the USB drivers).

Thanks for pointing me in the right direction and a great input method for my devices...if only swype was available on the Market...then I can easily upgrade the install on my Atrix.

MatUK.8
03-18-2011, 3:11 PM
I want the updated swype on my inspire. How do you get the update? I uninstalled it and registered again for a new swype beta email. Then when i go to install it, with the instructions from androidcentral (which is how i got it on my phone in the first place), it says there is an update for the installer available. but i get the "Install blocked" message. Why would swype send me the updated installer?
?

enduser2941
05-08-2011, 1:55 PM
Im sorry I have read the above but Im not sure that all of this answers the base question of what to do in the case where there is not option to select to install from an unknown source as stated in the installer for the the .apk swype file. Maybe I have missed something in the above but is all that really needed to just install swype? I would think that there would be an easier way to install the apk when there is not choice to select the install a file from an unknown source. Perhaps I am wrong here? Thanks!

enduser2941
05-08-2011, 1:59 PM
Question answered here http://forum.swype.com/showthread.php?2288-Phone-set-to-block-installation-of-apps-not-in-Android-market-ATT-Devices

Rick Cooley
06-13-2011, 10:29 AM
I saw this via the XDA Developer's forum. It's something AT&T wouldn't like you to, but I don't think it would count as a TOS violation. This will eat custom preferences like your wallpaper, but you can always set it back afterwards.

Go to Applications, All Applications, Customization Settings Provider, and click the Clear Data button. Then hit back, and go to Settings, and click the Clear Data button on that page. The place I read these instructions says it will wipe custom ringtones and the like, but I didn't lose anything but my wallpaper.

Also some people said that they lost the ability to send picture messages, but, again, that didn't happen for me, but I do want to warn people.

Once you do it, you can go into Settings, then Applications, and the Unknown Sources checkbox appears. Once you do that, you aren't blocked from installing Swype.

This is far easier than installing sideloading apps or messing around with adb.

Edited to add: mods, delete this post if it's in violation of TOS here. I just posted it because I'd had the same problem several others are having, and I'd seen the advice on other forums, and like I said, it's a lot easier than the other solutions.

t12121
06-18-2011, 4:29 AM
.....Go to Applications, All Applications, Customization Settings Provider, and click the Clear Data button. Then hit back, and go to Settings, and click the Clear Data button on that page. The place I read these instructions says it will wipe custom ringtones and the like, but I didn't lose anything but my wallpaper....


3rd party apps trick worked like a charm. So far I havent found any negatives from it.