PDA

View Full Version : Allow upgrades for carrier-preinstalled Swype



aphelion
12-27-2010, 9:16 PM
Sprint recently added Swype 2.7 to their latest OTA. However, I was using 2.15 before "upgrading" to the OTA. Now I'm stuck with an older version.

Is it possible to enable upgrades for the older carrier-installed Swype?

DonCorneo
12-27-2010, 10:26 PM
I think the OTA is the latest release version, while the Beta is still Beta, and Beta will always be a newer (hopefully better) version.
I'd guess once the current version in Beta is released to the Service Providers, preloaded Swype will be upgraded to that version (excepting compatibility and all that).

Besides that, there are differences between the release and Beta that causes problems for phones that are preloaded.

aphelion
12-28-2010, 9:13 AM
I cleared Swype out of the OTA by deleting /system/app/Swype.apk.

Then I could get to the Swype Installer again but instead of saying "invalid license" now it said "already available in the latest OTA".

It's frustrating to be stuck using an older version.

ScottyBrown
12-28-2010, 9:33 AM
I cleared Swype out of the OTA by deleting /system/app/Swype.apk.

Then I could get to the Swype Installer again but instead of saying "invalid license" now it said "already available in the latest OTA".

It's frustrating to be stuck using an older version.

But that older version is the latest stable release... Beta releases aren't meant for general use... and Swype wouldn't wan't a beta product to be pushed from an OEM I don't think.

aphelion
12-28-2010, 4:30 PM
I can't find any release notes / change log that indicates which releases are beta and non-beta. So I'm on board that 2.15 > 2.7.

That said, I found a way to get 2.15 back and working on the latest OTA. It wasn't easy and probably violates a bunch of terms and conditions, but as the saying goes, if the policy doesn't make sense, change it!