PDA

View Full Version : Can't download Swype BETA December Update



cybaba
12-07-2010, 3:52 PM
Hello,

I've been using Swype beta on my Nexus One android phone since a while. I recently received an email titled 'Swype BETA December Update!' with a link to download the latest beta. However when I follow that link on my phone I see 'access forbidden'. In general if I try to navigate to beta.swype.com from my phone I see 'access forbidden'.

Can someone help?

thanks,

regards,
Puneet

t8020rule
12-07-2010, 6:41 PM
I too am unable to download. My phone is an HTC Incredible running Android 2.2. I do not have any version of Swype on the phone currently.

Here is what I have tried:
1. Access email announcing Swype BETA December Update
2. Click on link (re: "...best viewed in your web browser")
3. Receive page with title Swype Beta for Android Updated Swype Installer and Application
4. Click on the link "Download the new Swype Installer & Beta here"
Receive page "You are downloading the Installer"
5. Seeing no evidence of download (I don't know what to look for), I click on the link "click here to download the installer manually".
6. A bubble momentarily appears which reads "starting download"
7. I see no further evidence of download.

What am I missing?

cybaba
12-07-2010, 11:18 PM
t8020rule, while i do not know a solution to your problem, mine got solved after rebooting the phone. Apparently something was wrong with the browser on my phone.

brian.resnik
12-08-2010, 7:22 AM
t8020rule: After the "starting download" bubble disappears, press the "menu" button on your phone, go to "More" and click the "downloads" option. This should show you all completed downloads, which will include Swype-Installer.apk. You can install the installer from there.

t8020rule
12-08-2010, 8:43 AM
Brian,
The steps to download in your post (menu -> More -> Downloads) was simple and worked the first time. Thank you. I encourage you to include those steps in the general instructions, otherwise naive users like me will get stuck and frustrated.

Again, thanks.

ahnicka
12-08-2010, 4:16 PM
I am having a problem. I have downloaded the installer, it shows up in my downloads and I then get the setting message. When I go to settings applications it isn't listed at all. Can anyone help me with this problem. I have an HTC aria if that helps.

ahnicka
12-08-2010, 4:19 PM
I can't find swipe in my applications. I am able to download it and find it in my download list but when I go to setting to allow it it is not shown. Can anyone help me? I have an HTC aria.

brian.resnik
12-08-2010, 4:19 PM
ahnicka: Unfortunately, Swype BETA cannot be installed on the Aria because AT&T has restricted their devices to not allow installation of applications from unknown sources. Sorry to say you're out of luck on this one :( Take it up with AT&T :P

chip802
12-24-2010, 10:55 AM
I just put the updated beta on my phone and no, I have not rooted it. I opened up the email on my phone, and it downloaded the .apk, then i opened up the phone "as storage device" and copied the .apk that was downloaded to my working directory with the adb.exe tool. i used "adb install Swype-Installer.apk" and installed the new installer on my phone. Then after some trials and aggravation, used "adb logcat" and watched the screen for logs pertaining to the installation as I hit the install button on in the installer program. It was there that I found this

I/ActivityManager( 79): Starting activity: Intent { act=android.intent.action.VIEW dat=file:///data/data/com.swype.android.installer/files/mypackage.apk typ=application/vnd.android.package-archive
mp=com.android.packageinstaller/.PackageInstallerActivity }
D/SwypeInstaller(17633): Swype Beta installation started...

I then used "adb pull /data/data/com.swype.android.installer/files/mypackage.apk" followed by "adb install mypackage.apk"

then I could carry out the setup of enabling swype as my keyboard and I am swyping up a storm.

Honestly, if you don't know what adb is or what the rest of these commands are, I recommend that you do not attempt to do this. what you do to your phone is up to you, but I take no responsibility for your actions here on out. I do not know what will happen when the next update comes in through the installer program, but for now - it works, and i'm happy! :D