PDA

View Full Version : Random all caps words



mikeymop
11-26-2010, 7:10 PM
I dont know if this is a bug, or theres some gesture that I'm accidentally hitting.

I haven't been able to manually reproduce the problem, but it does pop up every so often.

I'll be randomly Swyping words, and out of nowhere I'll get an all capital word, like I hit caps lock, however, I didn't hit the shift key on the keyboard and it isn't even lit up. It only happens for one word, I got two in a row once.
It's also not in the first word of a sentence it's always in the middle of sentences.

Any luck on reproducing this bug, or being aware of this bug?

rob.boehm
11-27-2010, 10:48 PM
You can type a word all in caps by Swyping from the first work to up above the keyboard, squiggling, and then swyping the rest. What may be going on is a finger from your other hand may be brushing against the screen from time to time causing this behavior. Or even a piece of dirt in the screen protector or seam on the glass can cause unwanted screen presses.

mikeymop
12-12-2010, 11:01 AM
Since I use the phone one handed my second finger cannot brush the upper part. I have tried for a few weeks to correct any possible user error and I can reproduce the bug a lot however I cant control when it comes up. I think the bug is caused by going to Swype as the keyboard is still coming up.

What I mean by this, is go to swype on the keyboard before the keyboard entry animation is complete, or something to do with changing threads on the android MMS app. I'm going to keep looking for a way to reproduce this bug, it seemingly only happens in the MMS app.

mleach99
12-13-2010, 10:46 AM
Having the same issue with the newest swype beta. Previous versions did not have this issue. I will go to swype for a txt or something and all my words will be caps. Only use one thumb to swype always, never 2 hands so its not other fingers. Also cannot reproduce issue either, it usually sneaks up on me when I'm not expecting it.

Sent from my nonsensikal froyo using Tapatalk

crosbyct
12-13-2010, 1:10 PM
This happens to me as well on my Incredible. Seems very random. It has probably happened 3 times this week. I never had the issue with previous versions.

itsmesamwtf
12-15-2010, 8:36 AM
This tends to happen to me most of the time.... again a one hand swyper using my thumb only...

camarosrool
12-16-2010, 7:43 AM
same as above :)
just chiming in to have something to check later to see if there is a fix :)

droid incredible one handed thumb swyper with random caps lock bug signing in

chaosmstr
12-16-2010, 2:41 PM
Original MT3G with latest beta, also having all caps issues.

Usually when starting a message, I find that I'm in caps lock mode, and have to hit the shift button to get out of it.

nightsechos182
12-16-2010, 5:06 PM
having the same issue. it's pretty random when it happens. slightly frustrating when you don't even notice until you swype the third word, but in retrospect that's how fast swyping is haha

skunis1
12-21-2010, 8:20 AM
I am having the same issue. It is random but has happened a few times since the update. I go to send a txt msg and the caps lock is already on. I only use one hand so I am not accidentally hitting anything.

NAU49ers
12-21-2010, 4:02 PM
I concur with everyone else on this thread. Happens to me about every fourth or fifth time i start a new text msg and starting happening with latest beta update.


Original Moto Droid

comodidit
12-23-2010, 8:45 AM
Swype v 2.17.59.15552 running on a MyTouch 3G slide with CM6.1

Caps lock randomly turns on. Happens about 5 times a day. Have to disable it with the shift key.

kmbear
12-23-2010, 9:37 PM
Happens to me and a coworker who just joined the beta. Both experience it about every 5th time, give or take. Occasionally more random than that, however.

VANdaMAN
12-27-2010, 3:57 AM
Same here. I typically notice this behaviour when Swyping the name of a contact in the text message "To" field. As soon as I touch the "To" field, the keyboard comes up in lowercase and then a second or two later it turns into all caps. Irritating! Is there a fix?

Motorola Milestone
Android 2.1 update 1
Latest Swype version (December)

Philby
12-30-2010, 10:50 AM
This also happens to me from time to time.

I notice it most often when I view a text from the notification bar, and select it to reply. When it opens the messaging app, my first word is often in all caps. Hard for me to notice cause generally the keyboard is all caps cause the first letter will be, but I don't want the whole first word to be.

HTC Hero. CM6.1 (Android 2.2). Stock Messaging App.

vsnlweb
01-01-2011, 11:19 PM
I am alos having this problem...

mikeymop
01-02-2011, 12:23 PM
I have a quick fix, turn off auto capitalization in Swype settings. Everything will be lowercase but it works

SGStrong
01-03-2011, 10:24 PM
Same problem. I have the original Droid running the latest beta. I never get all caps in the middle of swyping only when I begin to swype and always at random. Some days it may happen 0-1 time, other days it may be 6+.

winsettr
01-06-2011, 6:51 PM
I have noticed this on my HTC Aria CyanogenMod 6.1.1, but (as noted above) it only occurs when I access the message thread from the notification bar. The capitalization works just fine, even when responding to new messages, when I access the thread by opening the messaging app, then selecting the thread. Also of note, pressing the shift key before starting messages opened from the notification bar resets the capitalization to normal, as expected...

ikon810
01-13-2011, 12:10 PM
I have the same problem on my G2 CyanogenMod 6.1.1. I can't reproduce the issue easily but it seems to happen only when I'm starting a new message with swype. Another problem that seems to be related to this is that when I begin a new message, the keyboard is lowercase however, the first letter of the resulting word is capitalized.

In summary

1) Swype works as it should
2) It puts everything in caps
or
3) Keyboard shows lower case letters but the first letter of the word is capitalized.

dquestic
01-15-2011, 2:45 PM
I also have this issue, and it is annoying. MyTouch4G with CM7 Gingerbread rom.

1. When I bring up the swype keyboard it randomly types everything from that point in caps.
2. Clicking on caps and then reengaging caps returns skype to functioning.
3. It just seems that sometimes caps lock is assumed instead of just caps.

rob.boehm
01-22-2011, 3:31 PM
I've had this reoccur a few more times too. Noticed that the state the shift key is in isn't quite right all the time.

Even when nothing funny is happening the shift key icon is set to Caps Lock when composing a new message even though you don't get caps lock. I'm beginning to think this is occurring based on whatever was entered into Swype on the previous time Swype was used.

I haven't recreated Caps Lock being struck on, but here is the result of some testing I just did:

1)Open messenger, Type something, Press shift, Press send, Kill messenger, Reopen and shift key icon is still in the same state it was left in; Title case still works as designed.

2)Open messenger, Type something, Press shift twice, Press send, Kill messenger, Reopen and although Swype has the caps lock icon when the keyboard first loads it turns the icon off; however Title case still works as designed.

3)Open messenger, Type something, Press shift three times, Press send, Kill messenger, Reopen and although Swype has the normal shift key title case still works as designed.


I know this is a long shot, but for anybody experiencing this happening if you could report it AND remember what you previously typed in AND how you typed it in it could help us recreate the issue and solve it.

Malkavian
01-23-2011, 9:21 AM
I'm having this same problem. It's random, but does get annoying. I just check the caps lock before swyping. I'm on a Droid 1. This is a fabulous app and love it now that I have used it for a while.

Thanks
Michael

winsettr
01-24-2011, 3:50 PM
Last typed: an SMS, worked without error.

All caps in calendar application: placed a call, ended call, accessed calendar via Smooth Calendar widget, created new event, all caps appear when typing the name of the event.

CM6.1.1 on HTC Aria.

purplemarauder
01-25-2011, 1:25 AM
Nexus One on Vodafone UK
Stock Android 2.2

I think I might see a pattern.

I could be wrong, but I think it happens if the last time i used Swype (in any app), I exited with Caps on. i.e. this happens if I end an SMS with a fullstop and the auto-capitalize settings have set to caps ready for the next sentence. I then use back to return to wherever I was and the next time I use swype the Caps lock is on.

Hope that might help

PM

migr12858455
01-25-2011, 9:46 AM
This also has been happening to me but with a twist (of course). Droid 1, Cyanogen 6.x. swype beta 2.17.59.15552.r100. (intermittently) When I send a new text, the keyboard comes up in 123 mode,so I hit ABC and it comes up in CAPS mode. So I hit shift and type my message. I haven't been able to determine what causes it but it has happened recently and happens often now. I have been using all of the various swype versions for over a year now.

Also, I just checked and when it locks the caps, the keyboard shift button looks pressed in (whole thing lit up) and if I switch to 123 mode to type a "?" and send, in the next message I create, the keyboard "remembers" that and switches to 123 mode .. that is annoying - and of course sometimes switches to all caps.

I have to say with the last few updates swype is becoming less and less useful (and I am a DIE HARD swype user who has a physical keyboard and doesnt use it!).

migr12858455
01-25-2011, 10:07 AM
Possible explanation: Just tried a few tests. If I delete words back to the beginning, it goes into First letter caps mode (shift lit up). If I exit the text and create another the keyboard will "remember" its state and go back into First letter caps mode .. Now, I think I figured out the problem. If it "remembers" the caps mode and THEN tries to go into caps mode for the first letter, then I think it is going into all caps mode (double shift). They need to test whether the keyboard is already shifted before shifting it into first caps mode .. sound plausible?

brian.resnik
01-25-2011, 1:17 PM
I've submitted this issue to QA for testing. Hopefully we'll learn more in the coming days/weeks. Keep the ideas coming! The more bug reports we have, with more information, the more likely we are to find the problem! I've included the link to this forum thread in the report in our internal tracker, so the QA team will be able to check in here and see what new information there is.

Ketrel
01-26-2011, 9:26 PM
I'm using Handcent for texting.
When I send a text, and then end it with a period, usually by period and swyping to space, whatever I go into next time, rather than being in initial caps, it's in caps lock.

Ketrel
01-26-2011, 9:27 PM
If I had to guess (and I could be way off), it's basing the state of the caps lock as one more than the previous value, and ending the text like that would put it in shift, so a next use would be shift+1 so caps.

Aaron H
01-27-2011, 6:59 AM
Same issue. Friend has same issue (both are Droid 1).
Hopefully it can be resolved in the next update.

rael9real
01-27-2011, 7:57 AM
I get the same problem, also intermittently, only in the stock SMS app on my original droid. I have noticed that the button for the smilies, which normally appears when I write SMS messages, also goes away whenever this happens. After I send the message, if I write another one, it seems to be working fine, and the smiley button has returned.

mjweier
01-28-2011, 10:32 AM
I would have to agree with migr (I don't remember the letters after your name.) It seems that when swype gets left in a state where the shift key is left on (such as after I finish typing a text message and hit space after the period, starting the capitalization of the first word of that sentence) that it remembers that state when entering into another instance of the keyboard. When it remembers that state, it seems to want to capitalize the first word again, and doesn't notice that shift is already engaged, so it seems to engage the shift key one more time, resulting in caps being on.

I have had this issue numerous times, and have been trying to come up with a guess as to why it's happening.

I am on a Droid 1, BuglessBeast 0.6.2.1 OC'd to 1.2Ghz.

Have had the swype beta since it was released for the android OS.

Hoping this will get fixed in due time, but for now the tip left by another poster in this thread (didn't catch their name) was to turn off auto-capitalization, and this seems to work just fine. And since I'm just sending personal text messages, it's not a huge deal.

brian.resnik
01-28-2011, 4:58 PM
If you choose to turn off auto-caps, remember that there is a simple capitalization gesture too. Just drag your swype path above the keyboard immediately after whatever letter you want capitalized, then keep swyping. You can see a video on this (and lots of other great tricks) at http://www.swypeinc.com/tips-tricks.html

mleach99
02-02-2011, 9:54 AM
Hate to burst everyone's theory that it is the last value entered from the last time swype was used but...

After getting fed up with the random all caps, I came to the forum looking hopefully for a new version with a fix. I noticed the new lite version 2.17 so I installed it. Went to test it out and the first text I swyped with new version was all caps. So since I uninstalled the old version before installing the new one, I doubt the all caps is due to the last value being entered from when swype was last used. Maybe I'm wrong tho and something was retained from previous version?

Sent from my nonsensikal froyo using Tapatalk

rob.boehm
02-02-2011, 9:33 PM
I was having troubles with the theory as while the behavior of the shift button is repeatable, the actual behavior of Swyping is not. Thanks for the report though. difinitely interesting that out occurred immediatly after an install.

Btw I'm guessing you didn't restart after the uninstall right? Also what device were you using and what app did you swype in?

mleach99
02-03-2011, 10:19 AM
I was having troubles with the theory as while the behavior of the shift button is repeatable, the actual behavior of Swyping is not. Thanks for the report though. difinitely interesting that out occurred immediatly after an install.

Btw I'm guessing you didn't restart after the uninstall right? Also what device were you using and what app did you swype in?

LOL I'M GETTING ALL CAPS TRYING TO SWYPE THIS...WTF

anyway...i don't remember if I rebooted after the uninstall, don't think I did. Also the phone is a rooted droid eris running nonsensikal froyo rom cyanogenMod 6. The app I used was either google voice when trying to send a txt or the facebook widget to test swype right after the install, I wanna say it was facebook.

Sent from my nonsensikal froyo using Tapatalk

cyrussheets
02-15-2011, 7:25 PM
I just did get the beta version today, so perhaps it's just a "first day" kind of thing. Occasionally after opening a new text message instead of capitalizing the first letter and moving on it just leaves caps lock on.

I'm using a Motorola Droid with a stock ROM on 2.2.1

badgerdog
04-01-2011, 3:43 PM
Same issue here. For me, it is always after I end my first sentence. Almost half the time, the second sentence is caps locked. Behavior for me is when I swype the ending punctuation (period, exclamation, etc), Swype auto spaces then shifts, but shifts to caps lock instead of first letter only. I have never started a message (first sentence) in caps lock.

This is resolved by disabling Auto Capitalization as suggested.

vxaxv17
04-06-2011, 11:42 AM
I have only ever seen this in the beginning of messages, never in the middle of a message. I will usually type 2 or 3 words before i notice they are all caps and then just hit shift to bring it back to normal. I'll have to see what the last state of the caps button was when it happens again as i have not paid much attention to this in the past. Im on a droid incredible.

mniemann
04-06-2011, 8:58 PM
Any time I have an issue with all-caps, it is preceded by a slight slowdown. I think that if the phone is overloaded, whatever routine is called to try to "catch up" misses the fact that caps should have been shut off. I know when I encounter slowdown, the path that is drawn is not only delayed, but limited to nearly straight lines. Perhaps the step that discards/misses curve data also misses/discards whatever message would normally have been sent to stop capitalizing. It's hard to say for sure, since I am using a Droid Eris, which obviously stutters quite often, though these stutters don't always cause this issue.

rob.boehm
04-12-2011, 7:29 PM
Wanted to take the time to give a brief update here on some internal development. I've been running alpha builds on my phone for the past several weeks and do not recall a single issue of the all-caps issue occurring. However I will bring up that there are still several issues in these builds which cause me to curse at my phone, but once we get those usability issues hammered out hopefully this will be an issue of the past.

wtfywontudienow
06-06-2011, 10:23 AM
I have the same problem with swype, after some frustration I figured out the cause.

When composing a text message I usually type the whole sentence first, ending it with a period, question mark, or exclamation point by making the swype motion from the mark to the space bar. After I finish the sentence I usually check for any words that are incorrect, I then fix them by clicking them and using the swype key to pick the correct word from the word choice window. I noticed when I do this then move my cursor back to the end of the sentence swype enables caps lock and all proceeding words will be in caps. BUT this only happens if I make the swype from the period/? mark/! mark to the space bar to end sentences.

Now here's another funky thing, if I just tap the period, then fix a word, then tap the end of the sentence and continue, that word will come out lower case, without a space in between the peroid. If I tap the ? or the ! manually, fix a word, then tap the end of the sentence to continue typing, it inserts a space and capitalizes normally.

I guess a temp fix for now would be to fix words as I type, or fix words before I add a period, or other punctuation.

Droid X, running both 2.2.1 then 2.3.3.