PDA

View Full Version : Error with Nexus one update to android 2.2.1



SteelStiletto
11-24-2010, 7:34 PM
Device Make/Model: Nexus One
Wireless Carrier: T-Mobile
Android Version (2.2 FroYo? 1.6 Donut?): 2.2.1
ROM Version (Stock? Custom ROM?): Stock
Are you using APPS2SD?: No
Full text of the error message you are receiving (if you are not receiving an error, describe the problem in as much detail as possible): When going through the install process, I get an error "Download of the package failed. Swype is already installed. Please uninstall Swype and try again." after I finish installing Swype. Then, it is installed, but when I try to use it I get an error stating "Swype is configured for another device and will operate with limited functionality."
What troubleshooting steps have you completed so far?: I cleared settings and uninstalled, installed Swapper2, and reinstalled after a system restart, but still got the same error. I don't think that Swapper2 actually did anything, since I don't think I'm a root user.
Are you a ROOT user? (If you don't know what this means then the answer is "no"): Don't think so.

My issue didn't start until I got an over-the-air 2-part update bringing me from 2.2.0 to 2.2.1. I've reinstalled multiple times, but gotten the same results each time.

rob.boehm
11-25-2010, 7:42 PM
Yeah, swapper2 wouldn't have done anything with out root. It's interesting that this only started happening after 2.2.1. It's occurred twice in a row for you so far under 2.2.1 so far right?

Do you remember when exactly you last installed Swype under 2.2.0? Was it more than about 2 weeks ago?

This is probably happening due to a resource management problem that we encountered about 2 weeks ago with the latest update. For instance I can recreate the issue every time with my G1. On other devices, like the N1 or Evo, you might get lucky after several retries. It's probably worth it to give it another shot. If you do, copy a logcat to PasteBin so we can verify that this is indeed your case here. Instructions: http://forum.swype.com/showthread.php?994-POSTING-GUIDELINES-READ-ME-FIRST-Get-BETA-for-Android-troubleshooting-help#LOGCAT

Dinsdale
11-26-2010, 2:54 PM
I had the identical issue with my Nexus One (T-Mobile, 2.2.1, stock ROM, non-root, not installed on SD card). The third time was the charm for me - I stopped all the processes I could, made sure I had plenty of memory, and it installed without a hitch after two previous failures. I don't know if it was a memory issue or just the luck of the draw, but the first time I tried it with some of my superfluous stuff not running, it worked.

FWIW, this also started with my OTA update to 2.2.1, and I hadn't updated Swype for a couple of months at least previous to this issue.

SteelStiletto
11-26-2010, 7:47 PM
Okay, so I tried twice more, following all of the basic troubleshooting steps, and I still wasn't working. So, I went to install SendLog, and then started the steps again so I could put up a log, but then it finally worked! So, I guess the 6th time is a charm?