PDA

View Full Version : Broken Swype on Droid X



TexAgMJ
11-12-2010, 6:25 AM
Device Make/Model: Droid X
Wireless Carrier: Verizon
Android Version (2.2 FroYo? 1.6 Donut?): 2.2 FroYo
ROM Version (Stock? Custom ROM?): Stock
Are you using APPS2SD?: No
Full text of the error message you are receiving (if you are not receiving an error, describe the problem in as much detail as possible): "The application Swype... ...has stopped unexpectedly. Please try again."
What troubleshooting steps have you completed so far?: Tried reinstalling the original apk
Are you a ROOT user? (If you don't know what this means then the answer is "no"): Yes

I think I've ruined Swype on my Droid X, and I'm hoping I can get it working again.

Yesterday, when news about the update came about, I decided to try installing the update on my rooted Droid X. I used Titanium Backup to create a backup of the pre-installed version of Swype, uninstalled the pre-installed version, and used the Swype Beta Installer to install the newest beta.

It installed fine, but once I tried using it, it started continuously force-closing with the error message above. I quickly uninstalled and went to restore the backup of the pre-installed version I had made, but apparently Titanium doesn't properly backup system apps.

After doing some Googling, I found this thread (http://androidforums.com/droid-x-all-things-root/133158-how-reinstall-system-apps-_as_-system-apps.html) explaining how to reinstall the system apps from the DX system dump here (http://www.droidxforums.com/forum/droid-x-hacks/1356-droid-x-system-dump-those-who-deleted-apps-without-backing-up.html). I don't think this is the Droid X 2.2 version of Swype though, and I can't seem to find that one. I did exactly as it says, but even this version of Swype is continuously force-closing.

Is there any way that I can either get the new beta working or get the original pre-installed version of Swype for the Droid X working on my phone again?

Any assistance would be GREATLY appreciated, as I have really come to love Swype, and can't imagine not being able to use it anymore. Thanks in advance.

brian.resnik
11-12-2010, 10:37 AM
Unfortunately, there's not much we can do to help in this situation. Our packages or highly customized for each PreLoaded environment, so it's no wonder that using a different version of any kind would cause force close issues. The firmware is likely sending signals to Swype that it doesn't understand and causing it to panic and crash.

Your best bet is to try to get a hold of the original 2.2 RUU update for your Droid X and try flashing that. You may even need to do a full factory reset before/after flashing the RUU.

Sorry we can't help more. Thus are the risks of rooting and tinkering :\