PDA

View Full Version : Trace is laggy, line becomes jagged instead of smooth



LukeGT
11-07-2010, 5:51 AM
I'm not sure if this has been reported before, but I've searched and haven't found anything on it. It's been happening since I first started using swype quite a few months ago and the latest update MAYBE made it less frequent but it has still happened.

Sometimes, inexplicably, swype will lag in a very strange way. When you slide your finger over the keyboard, the line doesn't seem to detect any movement until you've moved a few millimetres, then it will suddenly draw a straight line from where your finger was moments ago to where it is now. It's as if the touch screen isn't able to detect small movements anymore. This makes it impossible to draw small circles on double letters because it won't detect that movement at all, and just draw a straight line. It also heavily impacts your accuracy.

Strangely enough, this error doesn't stay within swype. For example, If I go to my android homescreen and try to drag from one screen to the next, the screen jumps from place to place as I smoothly and slowly drag my finger across the screen.

As I said I'm not sure what triggers this, but I could be using swype for weeks without a problem and then suddenly this will crop up. The only way I've found to solve the problem (temporarily) is to reboot the phone.

I'm using an HTC Desire that was previously on a stock ROM but is now on Cyanogen (haven't had any problems with my brief usage of cyanogen)

Has anyone else experienced anything similar?
Has anyone got a solution?

Thanks

brian.resnik
11-07-2010, 8:19 AM
Sounds like a resource management problem. Your device's CPU could be getting bogged down with 3rd party apps, or a background process could be activating at that moment, thus stealing CPU cycles and causing lag in other applications. Let us know if this continues to happen with CyanogenMOD and I can instruct you on how to gather debugging logs to try to find out what's happening at that moment. Thanks!

rob.boehm
11-07-2010, 5:21 PM
Just to comment here I can basically guarantee this behavior on my G1. Like Brian said it's a resource management issue.

marrrio_
11-24-2010, 10:17 AM
I have a nexus one, and i too can confirm that with the NOV2010 update my swype became laggy. While swypeing the line lags and joins separate words together to make a long path and completely wrong word. Also, my nexus just seems a bit slower and lags in strange places.... love swype though

Jerry85032
11-24-2010, 11:13 AM
It sure is frustrating as all get out.

I can't say it's Swype -- I never use the phone without Swype.

Many times I've wanted Android to have a facility that gave me exact and specific lists of who was doing what in the last 10 seconds.

It does affect Swype badly, because of what happens to trace lines and word recognition. So, hint hint, it might be nice if Swype could include/create the (debug) facility I describe above. Turn on the debug mode and perhaps Swype creates a log saying, I got an input from Android at X time, and the next one at Y time, and in between Android says bad app Z was running.