PDA

View Full Version : Swype not working on Upgraded MyTouch 3G's (Froyo 2.2.1 - FRG83B)



Gbcue1
10-21-2010, 7:21 PM
Device Make/Model - T-Mobile MyTouch3G (no 3.5mm jack)
Wireless Carrier - T-Mobile
Android Version - 2.2.1 Froyo
ROM Version - Stock - just OTA updated today
Are you a ROOT user? - No
Swype Version: 2.4.44.10912.t100

So all the T-Mobile MyTouch3G's are being updated to Froyo 2.2.1. I got my OTA update today and Swype has ceased to work. It tells me the same message in the Nexus One 2.2.1 thread (http://forum.swype.com/showthread.php?1310-Nexus-One-2.2.1-FRG83-Swype-not-working).


The Swype package you installed is configured for another device and will operate with limited functionality. Please contact Swype about this issue.

I've un-installed (Swype & Installer) three times, and re-installed 3 times (after a fresh download), no go each time. I can see the swype trail, but it flashes a blue box and then nothing. Touch tap typing still works, though.

Does the MT3G profile in Swype's db need to be updated so that it knows it has Froyo now?

Thanks!

slicric
10-21-2010, 11:07 PM
im having the same problem with my upgraded my touch 3G

Gbcue1
10-21-2010, 11:19 PM
im having the same problem with my upgraded my touch 3G

http://forums.t-mobile.com/t5/myTouch-3G/Installing-Swype-Beta-after-Froyo-update/td-p/510320

That actually fixed it. Read the bold part.

rob.boehm
10-25-2010, 5:45 PM
This issue is also detailed here: http://forum.swype.com/showthread.php?993-KNOWN-BETA-for-Android-ISSUES-Please-read-before-posting-(UPDATE-9-23-10)

prshah
11-13-2010, 2:25 AM
Hey, thanks for this tip. I was facing the same problem, the same error message,

18

and the tip in the article about pressing the back key instead of clicking "Done" after installation did the trick. I pressed back, was taken back into the installer, and then a few seconds later, I got the message box of Swype successfully installed. A quick test in messaging showed it working fine!