PDA

View Full Version : Swype BETA only beeps, in Orange/Optimus Boston (Gigabyte Codfish)



FilCab
10-19-2010, 3:32 PM
Device Make/Model
Optimus Boston (the same hardware as the Gigabyte GSmart G1305 Boston/Codfish)

Wireless Carrier
Optimus (Portugal)

Android Version (2.2 FroYo? 1.6 Donut?)
2.1

ROM Version (Stock? Custom ROM?)
Stock Optimus ROM

Are you using APPS2SD?
No

Full text of the error message you are receiving (if you are not receiving an error, describe the problem in as much detail as possible)
None. The keyboard just beeps when trying to swype or pressing keys (and flashes a blue border).

What troubleshooting steps have you completed so far?
Reinstalled, didn't work.

Are you a ROOT user? (If you don't know what this means then the answer is "no")
No


Log in pastebin: http://pastebin.com/Zxb3ipwV

Notable errors in the log (I think):


E( 8314) Exception in ncbOpenRawFile '/data/data/com.swype.android.inputmethod/swypedata/-Latin1.zkb.le' error:files/-Latin1.zkb.le.mp3 (Swype)



W( 8263) No implementation found for native Lcom/swype/android/jni/SwypeCore;.nativeGetLanguageCodeFromName (Ljava/lang/String;)Ljava/lang/String; (dalvikvm)



E( 8263) java.lang.UnsatisfiedLinkError: nativeGetLanguageCodeFromName (AndroidRuntime)
E( 8263) at com.swype.android.jni.SwypeCore.nativeGetLanguageC odeFromName(Native Method) (AndroidRuntime)
E( 8263) at com.swype.android.jni.SwypeCore.getLanguageCodeFro mName(SwypeCore.java:1890) (AndroidRuntime)
E( 8263) at com.swype.android.inputmethod.SwypeApplication.bro adcastCurrentLanguage(SwypeApplication.java:563) (AndroidRuntime)
E( 8263) at com.swype.android.inputmethod.SwypeApplication.set Language(SwypeApplication.java:180) (AndroidRuntime)
E( 8263) at com.swype.android.inputmethod.SwypeInputMethodSett ings.onPause(SwypeInputMethodSettings.java:174) (AndroidRuntime)
E( 8263) at android.app.Activity.performPause(Activity.java:37 82) (AndroidRuntime)
E( 8263) at android.app.Instrumentation.callActivityOnPause(In strumentation.java:1190) (AndroidRuntime)


Thanks for the help.

rob.boehm
10-25-2010, 4:26 PM
This is a known issue with the installer which is detailed here: http://forum.swype.com/showthread.php?993-KNOWN-BETA-for-Android-ISSUES-Please-read-before-posting-(UPDATE-9-23-10)

Thanks! :)