PDA

View Full Version : [Q] Swype Beta No Longer Working on my N1. Tried Swapper2 Fix. Nothing



xguntherc
10-07-2010, 1:25 PM
Hey guys... I love Swype and would be extremely happy if someone could help me get this thing working again. I've used the BETA for a few months now.. I updated when I got the September update. Everything was all good.

I downloaded SwiftKey the other day. used it, and immediately went back to Swype as it's much better. But ever since then. I can't get swype to work no matter what I try.
I have a Google Nexus One, Running Cyanogen Mod 6.. Worked before, why wont it now. I've tried EVERY fix I've seen. I've made sure nothing is running during install. I've tried the latest Clear Data before uninstall. As well as the Swapper2 thing. It still wont work. I get the Error Swype Package Configured for another device or whatever.. I don't know what else to try. I'd love love love to have this back. Any help would be extremely appreciated.

Thanks!

Nexus One
CM6.0 Stable Plus some Nightly's.
Android 2.2.1

brian.resnik
10-07-2010, 1:41 PM
Please submit debugging logs (http://forum.swype.com/showthread.php?994-HOW-TO-READ-ME-FIRST-Get-BETA-for-Android-troubleshooting-help#LOGCAT) for both the installation process itself, and the first attempted launch of Swype after installation. Thanks.

xguntherc
10-07-2010, 1:44 PM
I will do that right now. Thanks Sir!.

you want em both to be posted here? or PM/Email to you

xguntherc
10-07-2010, 2:16 PM
Thanks for any help and your reply. Here are the Logs you requested. (expire in 1 Month). I appreciate any help you can give.

Log after Installation was complete
http://pastebin.com/raw.php?i=4kvTcvAh

Log right after launching the keyboard and getting the error
http://pastebin.com/raw.php?i=fEbYdB0t

xguntherc
10-10-2010, 8:17 PM
did those help you out at all?

rob.boehm
10-11-2010, 5:36 PM
Brian's the real expert here on these, but as you see he's on the other side of the world currently. x_x

I noticed these two entries at the end of each log file:

10-07 13:50:14.170 D/SwypeInstaller( 1243): Got empty license from server
10-07 13:50:18.480 I/global ( 1243): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
10-07 13:50:18.480 D/SwypeInstaller( 1243): Got license from server
10-07 13:50:18.500 D/SwypeInstaller( 1243): Got null result back from server
10-07 13:59:10.030 I/ActivityManager( 154): Starting activity: Intent { act=android.intent.action.MAIN cmp=com.swype.android.inputmethod/.SwypeInputMethodSettings }
10-07 13:59:10.120 E/Swype ( 1282): Could not open license from the APK: files/license.datMy understanding is that android is closing the installer application (Presumably to save resources) while installing before the license is saved to disk. If Swapper2 is not working for you use something like TasKiller to end all non-vital processes before installing.

xguntherc
11-11-2010, 2:55 PM
Thanks for checking back on this.. I'm getting the same error I had before now on you're latest BETA..

I'm going to give this one more run and hope I can get it to work. We'll see.. Any other advice? or could brian maybe look over the logs.

EDIT. GOT IT. Working!

Beaver2182
11-12-2010, 10:23 PM
I am on the same boat as xguntherc. My swype on my N1 isn't working either. Ive done everything to the T followed every step and it keeps doing the same thing. Need help with this too. Hopefully you guys can help cause I really really love my swype.