PDA

View Full Version : Issues with Beta



brianmorris
09-14-2010, 11:41 AM
Device Make/Model - Motorola Droid
Wireless Carrier - Verizon
Android Version (2.2 FroYo? 1.6 Donut?) - 2.2 FroYo
ROM Version (Stock? Custom ROM?) - Stock
Are you using APPS2SD? No
Full text of the error message you are receiving (if you are not receiving an erroMotorr, describe the problem in as much detail as possible)
What troubleshooting steps have you completed so far? ID of phone does not match registration on beta.swype.com
Are you a ROOT user? (If you don't know what this means then the answer is "no") - No


http://pastebin.com/ctJpx1tJ

rob.boehm
09-14-2010, 7:15 PM
Looks like your running into a memory issue during the install process

09-14 12:33:46.797 I/ActivityManager( 1116): Process com.swype.android.installer (pid 1660) has died.
09-14 12:33:46.797 I/WindowManager( 1116): WIN DEATH: Window{44206c10 com.swype.android.installer/com.swype.android.installer.SwypeInstaller paused=false}
09-14 12:33:46.860 D/dalvikvm( 1862): GC_EXPLICIT freed 836 objects / 58120 bytes in 42msYou can circumvent this issue by downloading SWAPPER off of the Android Market.

denism
09-16-2010, 8:44 AM
Device Make/Model HTC Magic
Wireless Carrier Vodafone AU
Android Version (2.2 FroYo? 1.6 Donut?) 2.2 FroYo
ROM Version (Stock? Custom ROM?) Cyanogen 6
Are you using APPS2SD? No
Full text of the error message you are receiving (if you are not receiving an erroMotorr, describe the problem in as much detail as possible)
"already installed" usually, "limited functionality" on some installs. "Language" in the settings is forever grayed out :(
What troubleshooting steps have you completed so far?
Clear, delete, clear downloads, download, restart, killed running apps, reinstalled more times than I can count.
Tried unchecking Swype, tried leaving it checked.
Tried unchecking "unknown sources" because someone somewhere said that made it work
Run with Swapper2
Run with Swapper for Root
Stopped using SlideScreen, tried all different types of launchers.
Tried restoring a backed up Swype v1.whatever BETA to /data/app and /data/data, re-flashing CM6, running fix_permissions and sync
Messed around with Cyanogen's performance settings -- JIT on/off, VM heap size 16m and 24m
Tried killing everything incl. home screen, freeing up 20MB+, navigating with long-press home to install
Are you a ROOT user? (If you don't know what this means then the answer is "no") Yes

http://pastebin.com/kuKAKXnp
This run involved (with Swapper for root):
Clear data, uninstall (both Swype and Installer).
Clear download folder.
Download file.
Reset.
Kill background tasks.
Install & run installer.
Install Swype.
Run "SendLog" at the "installation complete scren" (pastebin)
Restart.
Load Messaging.
Swype works but there's no available languages.

And that's where I'm at now. It's 2:40am, it's the second night in three days since I got the email that I've stayed up late trying to get this thing to work. Going back to normal keyboard is absolutely killing me, and I'm now totally out of anything else to try.

I'm really really regretting uninstalling a perfectly working Swype for this non working upgrade :(:(