PDA

View Full Version : Configured for another device



Legion09
09-13-2010, 9:11 PM
Was told to post a new thread concerning my issue, here is my dilemma....I routinely swap roms and haven't used swype in a while because of it, decided I wanted to re-install it and it does not work, here is the troubleshooting...

Device Make/Model: HTC Dream (T-mobile G1)

Wireless Carrier: T-Mobile

Android Version (2.2 FroYo? 1.6 Donut?): 2.2 FroYo

ROM Version (Stock? Custom ROM?): Cyanogen 6.0.0 DS

Are you using APPS2SD?: No

Full text of the error message you are receiving (if you are not receiving an error, describe the problem in as much detail as possible): "The Swype package you installed is configured for another device and will operate with limited functionality. Please contact Swype about this issue."

What troubleshooting steps have you completed so far?: All basic troubleshooting steps as per directions.

Are you a ROOT user? (If you don't know what this means then the answer is "no"): Yes

PasteBin LogCat report: http://pastebin.com/ThvMSXh6


I was given these steps to attempt to fix the problem.


Regarding the following posts. Not too sure what's going on with your install logs.

Brad Hellmann http://forum.swype.com/showthread.ph...=6528#post6528
Legion09 http://forum.swype.com/showthread.ph...=6548#post6548
mjamidon224 http://forum.swype.com/showthread.ph...=6637#post6637

I'll have to check with Brian; however I found a couple posts with similar messages that were resolved by doing the following:
Uninstalling Swype and Swype Installer from the phone
Removing all items from your Download folder on your SD card
Rebooting the Phone
Re-download the Swype Installer and reinstall Swype.

These steps did not work. Same error as above, did the process several times to no avail. Please help. Thank you.

lolmensch
09-14-2010, 2:14 AM
for me it worked this way:

i enabled swap (with firerats script/patch) and compcache (in cm settings).
I unchecked "keep home in memory" (in cm performance settings)
with a task manager i killed all apps beside home app.


As said in a sticky thread, android kills the installer during the installation, so for me it worked the way described above.