PDA

View Full Version : Swype Installer is expired. Login at beta.swype.com to get a new version.



Nick040489
09-11-2010, 8:00 AM
I'm having the same problem after switching devices from a hero to an intercept. I had emailed the support email before the forums went up about five times and got no response each time.

Samsung Intercept
Sprint
Android 2.1
Stock ROM
Not using Apps2SD
Error Message: The ID of this phone does not match your registration at beta.swype.com.
I have done the troubleshooting steps about five times to with no success.
My phone is not rooted.

http://pastebin.com/zV6dm0SJ

SixSicSix
09-11-2010, 2:14 PM
Motorola Droid
Bugless Beast 0.4 (FroYo)
ChevyNo1 1.25 GHz 7step kernel
Latest Swype Installer from beta.swype.com/android/get

(Swype Installer version shows 1.0.10912)

I followed the uninstall here: https://beta.swype.com/android/welcome/detailed/#uninstall

And then reset myself the activation email, downloaded the Swype installer and installed it. I then ran the Swype installer and logged in.

When attempting to hit the Start Download button after logging in with the Swype Installer I get this message:

"Swype Installer is expired. Login at beta.swype.com to get a new version."

Only thing is, I've already done that :(

Darkside
09-11-2010, 2:25 PM
Just got the same issue with Droid running CyanogenMod 6.0.0.

Been running Swype for a while no with no issues. Don't know what I will do with out it. Help!

SixSicSix
09-11-2010, 2:26 PM
It's very painful to type without Swype D:

CoffeeGrinder
09-11-2010, 4:14 PM
I have this problem as well!

au1776
09-11-2010, 4:17 PM
Same for me. It seems I'm downloading Installer 1.1, but when it goes to install, it says version 1.0.

milrtime83
09-11-2010, 4:22 PM
Here too. I got the email saying it was updated and the version of the Installer that I am getting is 1.0.10912. When I try to download swype it gives me the same message. And now I am annoyed that I have already uninstalled the old version and don't have a working version on my phone.

edit: In the installer it says version 1.0.10912. In the applications menu when I go to uninstall it the version is shown as 1.1.

Exodus615
09-11-2010, 4:22 PM
same here and ive done this numerous times when is swype going to address the issue? hell i even tried to install it really fast lol - Motorola Droid Bugless Beast v0.4 (Froyo)

PopeXXIII
09-11-2010, 4:31 PM
Same issue here. Droid running Cyanogenmod 6.0.

tommyz
09-11-2010, 4:37 PM
Same for me and I'm running a Droid with 2.2 from OTA update. Non-root and non-ROM.

brian.resnik
09-11-2010, 4:41 PM
We are in the process of rolling out a new version right now. Looks like some of you got the new downloader before we had the new Swype package ready to go. Please be patient and you will receive an email within the next 24hrs to let you know the update is available for you!

CoffeeGrinder
09-11-2010, 4:45 PM
We are in the process of rolling out a new version right now. Looks like some of you got the new downloader before we had the new Swype package ready to go. Please be patient and you will receive an email within the next 24hrs to let you know the update is available for you!

I did get an email letting me know the update is available for me....

That's where I got the download link from, the email.

Sorry if I misunderstand.

takeshi
09-11-2010, 4:51 PM
I did get an email letting me know the update is available for me....

That's where I got the download link from, the email.

Same here. I downloaded using the link in the email that I received today only to have the same problem.

au1776
09-11-2010, 4:52 PM
Thanks Brian, hopefully it'll be up soon.

mrsjam
09-11-2010, 5:02 PM
We are in the process of rolling out a new version right now. Looks like some of you got the new downloader before we had the new Swype package ready to go. Please be patient and you will receive an email within the next 24hrs to let you know the update is available for you!

so this is going to fixed, cuz i love my swype keyboard. will we be getting a new when the updated is corrected?

Roland Stone
09-11-2010, 5:03 PM
Ditto for me Droid 1 simply stunning 4.7

jschriesheim
09-11-2010, 5:05 PM
Just got the update email. Followed instructions and had the same error as above (at 8pm EDT). Running Droid w/Froyo.

katahdin
09-11-2010, 5:05 PM
Moi aussi !

le_avion
09-11-2010, 5:08 PM
I received the email notifying me of the new version. I downloaded and installed the new installer. When running it it shows Ver. 1.0.10912. The application manager displays version 1.1 for the installer. When trying to install the new swype I get the same "Swype Installer expired error." Why does the swype installation have to be so complex?

If you received the above error and later managed to get the new version installed please post here so the rest of us knows that we should try again.

BTW, why can't we just download the swype package and install it without the intermediate installer?

jgmooooooo
09-11-2010, 5:12 PM
I tried to install the update that came out today. I get this error message.
"Swype Installation Failed"
"Swype Installer is expired. Login at beta.swype.com to get a new version"

I have follow all of the steps that were suggested in the forum that explains how to update to new version...5 times!

Phone Make/Mode - Droid 1
Android OS - Froyo 2.2
Swype Version...uninstalled old and trying to uninstall new
What Behavior did I expect to see...Installation/Update
I keep getting the error above
I uninstalled the old version of Swype first.
Device is not rooted

megaera
09-11-2010, 5:17 PM
So, are we going to get a second email in addition to the original email telling us when it is REALLY ready?

Joseph Cutrona
09-11-2010, 5:20 PM
Yeah I am having the exact same issue... I received the email telling me to uninstall Swype and the Swype installer, then go to the link in the email and download the new version. I am getting the message that the installer I JUST DOWNLOADED is expired.

Droid 1, BuglessBeast v.04

zman0125
09-11-2010, 5:21 PM
Any update?

AceMilo
09-11-2010, 5:22 PM
I just saw a post about the new version of the installer and that the old one will expire soon, so I uninstalled the old one, rebooted, downloaded the new one, installed it, put in my credentials, and tried to download the new version. It told me that the version I have is already expired and refuses to download the new version. What gives? I'm on a moto droid, rooted, running a custom rom (bugless beast 0.4). Every time I try to uninstall and reinstall it, it just says it's expired even though I just downloaded it from the site.

Thanks

AndroidApplabs
09-11-2010, 5:27 PM
Same problem here. Received the email, deleted Swype, and then got the Expired message.

It would just be nice to know if we will get another email, or we should check back after a specific time or just keep refreshing this thread.

AceMilo
09-11-2010, 5:33 PM
Yep, me too. Saw the post on android central, grabbed the installer, now I'm screwed unless I restore a nandroid backup. This sucks, I need my swype!

Joseph Cutrona
09-11-2010, 5:34 PM
34

Notice the two DIFFERENT version numbers.

It looks like, on my device anyway, that the installer is not pointing to an appropriate download location.

StingRay
09-11-2010, 5:38 PM
Having same issues as others. No working version of Swype now on phone....

I'm puzzled as to why Swype downloading, activation, installation, etc. is so much more difficult than other apps available. While it is one of my favorite apps, this whole process seems quite unnecessary.

droiddroid
09-11-2010, 5:38 PM
I just received a single email telling me to uninstall. Now I go to install and get through the process to find out I cannot. Now I have no Swype and I am just going to sit here and cry. You guys grrrrr. messed up my texting life for the next day or two. Are we going to recieve another email telling us this time we really can install the Swype?

johnlgalt
09-11-2010, 5:45 PM
Same issue here as well.

I also deleted the old installer off of my phone, so I am stuck trying to install this version.

It seems when I manually clicked the install to download the first time it was giving me an error that the screen size was not appropriate, which leads me to believe that there is an issue with the installer download itself, leading to the failed install of Swype.

aviedo
09-11-2010, 5:46 PM
I too received an email and after uninstalling my current version of Swype and the installer I clicked the link in my email to download the new installer and got the same error about the new installer being expired. So I guess you are not the only one who does not understand Brian's response.

dmbfan36_23
09-11-2010, 5:49 PM
I have the exact same problem as everyone else... followed the directions in email and now I can't re-install swype due to the expired installer?! #NotCool

Thank god for Titanium Backup though! I was able to restore version 1.56.30.7625.t100...

undone430
09-11-2010, 5:50 PM
I am also having issues with the installer. I installed this several times after uninstalling Swype and it tells me that the swype installer is expired. I also have to Motorola Droid.

Massachute
09-11-2010, 5:54 PM
This is ridiculous. I too got the update e-mail a few hours ago. It's now many hours since it appears other people first faced this problem, and of course I'm facing it too. The rigamarole surrounding all of this is absurd. Why send out the update message before the update is available, and why isn't the problem fixed by now? (And why isn't Swype out of beta and on the Market so we can avoid all of this. But of course that's another question.)

And of course each time I try, I have to enter my e-mail and password all over again, using the bad built-in keyboard that I'm not used to. And the installer doesn't even seem to recognize when the phone (a Droid) is turned 90, like every other program does, rendering the whole process even more annoying. Ugh!

dccrens
09-11-2010, 5:57 PM
Same problem here. Titanium will restore the installer but o get the same error. This sucks.

aviedo
09-11-2010, 5:58 PM
Brian, I did receive an email and it was the link in this email that I used to download the new installer after uninstalling my current version of Swype and the old installer. I got the "Swype installer is expired" error using the email that was intended for me. What do you suggest I do now?

jhmover
09-11-2010, 5:59 PM
I love Swype but it is the ONLY application I ever have problems installing. Here we go again. Wouldn't it be easier just to put it in Market and have it install like everything else?

hustler616
09-11-2010, 6:05 PM
I also received Email about 2hrs ago and now do not have swype. I am also receiving the "Swype installer is expired" message. I hope this does get taken care of as I cant imagine typing without Swype.

mrrvomun
09-11-2010, 6:08 PM
Yep, same problem here too.

To those of you saying 'just distribute it this way,' they distribute it using an installer app to prevent ppl who aren't part of the beta from downloading it. As such, they don't want to provide a direct link to the app, but they will let you download an app that downloads the actual keyboard from an undisclosed location (provided you have proper authorisation). Very good idea for preventing outside access, that.

johnlgalt
09-11-2010, 6:18 PM
Sorry, Brian, but that is the exact version that shows on the front of the Swype installer.

When uninstalling it from the phone, though, via Settings --> Applications --> Manage applications, the version shows as 1.1.

FWIW, I am trying to install it on my Motorola DROID running an alternate ROM, LFY 1.6 (Smoked Theme) based upon Android FRG22D (FroYo), and am rooted, if that helps.

I have currently restored my previous version until this gets sorted out.

Is it possible that after uninstalling the old versions the devices need a full reboot in between attempting to install the new version of the installer?

johnlgalt
09-11-2010, 6:19 PM
@Brian:

Feel free to contact me directly for additional troubleshooting, if you'd like...

If you need contact info (other than above) PM me.

dmbfan36_23
09-11-2010, 6:20 PM
Hi everyone. We hear you on this. What we need from you is to first check the version number on the installer. The most updated installer version is Ver 1.0.10912. If you are using ANYTHING other than that, you're using the wrong installer.

Brian,

I have the correct version. I have tried this 3 times.. complete uninstalls, deleted installer on SD card, rebooted phone, re-downloaded installer and tried again. Each time, after entering the username and password, you get the expired message.


If no one else does the SendLog thing, I will.

brian.resnik
09-11-2010, 6:26 PM
Sorry for the confusion everyone. I made that post in response to some posts from earlier in the day, when the emails hadn't started going out yet.

We need to know a couple things:


Is your INSTALLER version number Ver 1.0.10912?
Is your screen one of the following sizes: WVGA 480x840 WVGA854 480x854 HVGA 320x480
Did you uninstall both Swype and SwypeInstaller first?


If the answer to all three questions is yes, please post your debugging logs as described here (http://forum.swype.com/showthread.php?994-HOW-TO-READ-ME-FIRST-Get-BETA-for-Android-troubleshooting-help#LOGCAT)

Thanks!

Mephistophenes
09-11-2010, 6:35 PM
@brian that's great, but like the OP and others have said, we ARE clicking on the link in the e-mail Swype sent us!

Ozirus33
09-11-2010, 6:36 PM
Since the last beta and now including this one I have had a replacement Motorola Droid and cannot install Swype onto it because I receive the error that the ID of the phone does not match the ID at registration. I have tried all of the FAQ solutions and some around the internet to no avail.

Motorola Droid
2.2 Froyo
MEID: A0000022045DB0
Swype Installer 1.1 (Downloaded from the newest round of beta emails.
I expected to be able to install Swype,
but instead received an error that says "The ID of this phone does not match your registration at beta.swype.com"
Swype and SwypeInstaller were both uninstalled
The device is not rooted

Thank you for your time

dmbfan36_23
09-11-2010, 6:39 PM
Sorry for the confusion everyone. I made that post in response to some posts from earlier in the day, when the emails hadn't started going out yet.

We need to know a couple things:


Is your INSTALLER version number Ver 1.0.10912?
Is your screen one of the following sizes: WVGA 480x840 WVGA854 480x854 HVGA 320x480
Did you uninstall both Swype and SwypeInstaller first?


If the answer to all three questions is yes, please post your debugging logs as described here (http://forum.swype.com/showthread.php?994-HOW-TO-READ-ME-FIRST-Get-BETA-for-Android-troubleshooting-help#LOGCAT)

Thanks!
1. Yes
2. Yes, WVGA854 480x854
3. Yes & Yes

Here are logs that I got using aLogCat, filtered for Swype:
http://pastebin.com/1xKWZwiv

brian.resnik
09-11-2010, 6:44 PM
I'm sorry but I'm not familiar with the formatting that aLogCat uses. Please try either SendLog or Log Collector. Both produce standard Android logcat output

johnlgalt
09-11-2010, 6:45 PM
Yes, installer version is 1.0.10912
Yes, I have a Motorola DROID (original) with Screens size WVGA854 @ 480 x 854 res
Yes, I uninstalled both, rebooted, opened email, clicked on link to download installer, let it download, rebooted, installed downloaded installer, rebooted, then attempted to install Swype.


Link to my Pastebinned log: http://johnlgalt.pastebin.com/4FaX44U8

HTH

fgonzo98
09-11-2010, 6:46 PM
excellent! thank you!

johnlgalt
09-11-2010, 6:50 PM
Of particular note is line 271: -
09-11 21:40:15.417 D/SwypeInstaller( 1930): Server says that this installer has expired.

And then lines 320 - 331:
09-11 21:40:19.183 I/ActivityManager( 1093): Process com.swype.android.installer (pid 1930) has died.
09-11 21:40:19.190 I/WindowManager( 1093): WIN DEATH: Window{4645a0c0 com.swype.android.installer/com.swype.android.installer.SwypeInstaller paused=false}
09-11 21:40:19.190 I/WindowManager( 1093): WIN DEATH: Window{4646b618 Swype Installation Failed paused=false}

tyggtygg
09-11-2010, 6:52 PM
Like John:


Yes, installer version is 1.0.10912
Yes, I have a Motorola DROID (original) with Screens size WVGA854 @ 480 x 854 res
Yes, I uninstalled both, rebooted, opened email, clicked on link to download installer, let it download, rebooted, installed downloaded installer, rebooted, then attempted to install Swype.

here is my log:
http://pastebin.com/vESZ876r

Joseph Cutrona
09-11-2010, 6:53 PM
My answers are yes to all as well.

Log is here:
http://pastebin.com/ZSidNDte

johnlgalt
09-11-2010, 6:56 PM
Like John:


Yes, installer version is 1.0.10912
Yes, I have a Motorola DROID (original) with Screens size WVGA854 @ 480 x 854 res
Yes, I uninstalled both, rebooted, opened email, clicked on link to download installer, let it download, rebooted, installed downloaded installer, rebooted, then attempted to install Swype.

here is my log:
http://pastebin.com/vESZ876r

Your line 410 is the same as my line 271, but with a different ProcessID (to be expected):


09-11 21:31:04.822 D/SwypeInstaller( 1705): Server says that this installer has expired.

le_avion
09-11-2010, 6:56 PM
http://pastebin.com/vZAz3SBd

This is a Droid 1 running official Froyo

johnlgalt
09-11-2010, 6:57 PM
Yours is at line 544:
09-11 20:50:49.973 D/SwypeInstaller( 2176): Server says that this installer has expired.

jhmover
09-11-2010, 7:01 PM
I've tried all of this. I used the link in the e-mail, downloaded, re-booted, removed app manager program I get the same message everyone else does. I did note the installer is version 1.0.10912 pm the screen where you log to complete installation, but when you uninstall it is says it's version 1.1

johnlgalt
09-11-2010, 7:02 PM
I've tried all of this. I used the link in the e-mail, downloaded, re-booted, removed app manager program I get the same message everyone else does. I did note the installer is version 1.0.10912 pm the screen where you log to complete installation, but when you uninstall it is says it's version 1.1

You'll want to follow the instructions in this post that Brian made a couple of pages back:

http://forum.swype.com/showthread.php?1108-Swype-Installer-is-expired.-Login-at-beta.swype.com-to-get-a-new-version.&p=6256#post6256

dmbfan36_23
09-11-2010, 7:09 PM
I'm sorry but I'm not familiar with the formatting that aLogCat uses. Please try either SendLog or Log Collector. Both produce standard Android logcat output
Here are the logs from SendLog:
http://pastebin.com/prFywcvm

...and I too have the same line that others do:

09-11 22:04:23.303 D/SwypeInstaller( 4973): Server says that this installer has expired.

brian.resnik
09-11-2010, 7:12 PM
UPDATE This has likely been narrowed down to an installer issue which is only effecting the Motorola Droid original running FroYo. We're working on a fix.

jhmover
09-11-2010, 7:13 PM
Good this is making me crabby :-) I get the same installer has expired.

hustler616
09-11-2010, 7:16 PM
UPDATE This has likely been narrowed down to an installer issue which is only effecting the Motorola Droid original running FroYo. We're working on a fix.

That is great news Brian.. Thank you for the updates and time you spend trying to get this fixed

johnlgalt
09-11-2010, 7:23 PM
UPDATE This has likely been narrowed down to an installer issue which is only effecting the Motorola Droid original running FroYo. We're working on a fix.

Thanks, Brian. At least we know the issue now...

FastKatt
09-11-2010, 7:30 PM
Next time I'll check here before I listen to an email from the SWYPE team...
@#$% it to *&^%
Hoping to be able to install this tomorrow morning...
Turning my phone off now, so I don't see any text messages...
Seeing as I can't comfortably reply to them...
Good night all & good luck with the update!

CoffeeGrinder
09-11-2010, 7:38 PM
the problem is also with Motorola milestone

jjkoztec
09-11-2010, 7:44 PM
UPDATE This has likely been narrowed down to an installer issue which is only effecting the Motorola Droid original running FroYo. We're working on a fix.

Good deal. I'm looking forward to a fix. I tried another swype-like keyboard but it just didn't work as well as Swype does.

asten77
09-11-2010, 7:46 PM
UPDATE This has likely been narrowed down to an installer issue which is only effecting the Motorola Droid original running FroYo. We're working on a fix.

Brian: For what it's worth, I am running a Motorola Milestone (UMTS version of the DROID).. the Telus Canada version, if it matters, and also experiencing this issue. While DROID and Milestone are nearly identical, they do have different software in case that matters.

brian.resnik
09-11-2010, 7:47 PM
Solution!

Thanks for the help, everyone! Apparently we fat-fingered a setting in our server-side download manager. Entered the wrong resolution for the Droid! Hah! We've resolved the problem and you can all start downloading again! Let us know if you still have problems.

hustler616
09-11-2010, 7:53 PM
Thank You Brian, it is now working again.. thanks again to you and the team for getting it taken care of.

bljewell
09-11-2010, 7:59 PM
Same issue here. Moto Droid FRG22D. Did not have problems with previous Android updates nor other Swype beta updates.

CoffeeGrinder
09-11-2010, 7:59 PM
Thank you. I'm typing this on swype.

le_avion
09-11-2010, 8:01 PM
Works now. Thank you!

Icculus760
09-11-2010, 8:05 PM
I went almost a whole day without Swype on my Droid...this thing's worse than crack (no offense to crackheads :)

johnlgalt
09-11-2010, 8:08 PM
Installing right now - about to make a test post...

Grr, got a message that Swype was already installed. Sigh.

Off to uninstall everything, clear caches, reboot, then start the process all over again.

AceMilo
09-11-2010, 8:12 PM
YAY!!! I had to use titanium to get it back temporarily, but the fix finally worked! Failed the first time, had to uninstall everything and reboot to get it to work, but its all good now!

bljewell
09-11-2010, 8:13 PM
Same issue here. Moto Droid FRG22D. Did not have problems with previous Android updates nor other Swype beta updates.

Hey!
The update works!
Thanks for getting it fixed so quick

brian.resnik
09-11-2010, 8:37 PM
Installing right now - about to make a test post...

Grr, got a message that Swype was already installed. Sigh.

Off to uninstall everything, clear caches, reboot, then start the process all over again.

Here's the steps I take when I'm having problems on my own device, just to make absolutely sure.

1. Make sure Swype and SwypeInstaller are both INSTALLED (even if showing errors when trying to use)
2. Go to Settings -> Language & Keyboard and UNCHECK Swype.
3. Go to Settings -> Applications -> Swype Press CLEAR DATA. Then press UNINSTALL.
4. Go to Settings -> Applications -> SwypeInstaller Press CLEAR DATA. Then press UNINSTALL.
5. Delete everything from the download directory on my SDcard
6. Force Stop every process I can without making the system unusable in Settings -> Applications -> Running (tab)
7. Install the update.

I've never NOT been able to install Swype after this process.

AndroidApplabs
09-11-2010, 9:25 PM
Solution!

Thanks for the help, everyone! Apparently we fat-fingered a setting in our server-side download manager. Entered the wrong resolution for the Droid! Hah! We've resolved the problem and you can all start downloading again! Let us know if you still have problems.

Thanks for the fix!

It is really a testament to your great product that everyone was so panicked about having to use another keyboard.

I personally was lost trying to use the stock Android keyboard - I kept trying to "swype" it. It seemed completely archaic to have to press each individual key!

Thanks again for all your hard work!

jhmover
09-11-2010, 9:48 PM
Worked fine. Thanks! You have a great product and I shudder at the thought of having to use anything else on my Droid 1. You definitely have a customer.

megaera
09-11-2010, 10:19 PM
Fixed on mine. Droid. Bugless Beast .4. Must have been a timing issue between the email and the package.

johnlgalt
09-11-2010, 10:26 PM
Here's the steps I take when I'm having problems on my own device, just to make absolutely sure.

1. Make sure Swype and SwypeInstaller are both INSTALLED (even if showing errors when trying to use)
2. Go to Settings -> Language & Keyboard and UNCHECK Swype.
3. Go to Settings -> Applications -> Swype Press CLEAR DATA. Then press UNINSTALL.
4. Go to Settings -> Applications -> SwypeInstaller Press CLEAR DATA. Then press UNINSTALL.
5. Delete everything from the download directory on my SDcard
6. Force Stop every process I can without making the system unusable in Settings -> Applications -> Running (tab)
7. Install the update.

I've never NOT been able to install Swype after this process.

Brian, I had to pretty much do the same thing to get it working on my phone.

Nice to know that that is a good working procedure for getting it working if it thinks that it is still installed...

kprz24
09-12-2010, 4:15 AM
ok i think i am the only one with this problem i cannot log in to the beta at all i was wondering if i could borrow one of your logins. email me if you dont want to post here kprz2424@gmail.com

FastKatt
09-12-2010, 9:08 AM
ok i think i am the only one with this problem i cannot log in to the beta at all i was wondering if i could borrow one of your logins. email me if you dont want to post here kprz2424@gmail.com

^^^ LOL ^^^
That's funny right there!

kprz24
09-12-2010, 10:09 AM
^^^ LOL ^^^
That's funny right there!

its really not funny i just want swype

or can someone give me a link or email me the swype.apk not the installer

takeshi
09-12-2010, 10:22 AM
or can someone give me a link or email me the swype.apk not the installer
If you truly forgot your password here's the Forgot Password link:
https://beta.swype.com/android/user/lostpassword/

BonanzaMan
09-12-2010, 10:32 AM
Cannot install the update on my Droid. Yesterday I got the same message as everybody else. Today I get the error that the program is already installed or simply that the download failed. I went thru my SD card and deleted everything related to Swype. No joy. So nevermind. I'll just reinstall the Milestone edition floating around the Net. Better luck next time with your update.

brian.resnik
09-12-2010, 10:33 AM
BonanzaMan: please check the Known Issues thread, as we've recently updated it to include a possible fix for the "already installed" issue.

kprz24
09-12-2010, 1:26 PM
If you truly forgot your password here's the Forgot Password link:
https://beta.swype.com/android/user/lostpassword/

i tried to do that and they sent me anemail that said thank you for registering

FastKatt
09-12-2010, 3:05 PM
Now it's installed & fails to work...
Says it's not for my phone...

mpenda
09-12-2010, 3:32 PM
Same thing here......had the expired version problem, and one that was fixed, I now get the "not configured for this device" error.
Ah the joys of Beta software! ;)

brian.resnik
09-12-2010, 5:34 PM
For those having problems with installing after the Droid "installer expired" error, try this:

Make sure Swype and SwypeInstaller are both INSTALLED (even if showing errors when trying to use)
Go to Settings -> Language & Keyboard and UNCHECK Swype.
Go to Settings -> Applications -> Swype Press CLEAR DATA. Then press UNINSTALL.
Go to Settings -> Applications -> SwypeInstaller Press CLEAR DATA. Then press UNINSTALL.
Delete everything from the download directory on your SDcard
Force Stop every process you can without making the system unusable in Settings -> Applications -> Running (tab)
Install the update.

jkrell
09-12-2010, 6:04 PM
For those having problems with installing after the Droid "installer expired" error, try this:

Make sure Swype and SwypeInstaller are both INSTALLED (even if showing errors when trying to use)
Go to Settings -> Language & Keyboard and UNCHECK Swype.
Go to Settings -> Applications -> Swype Press CLEAR DATA. Then press UNINSTALL.
Go to Settings -> Applications -> SwypeInstaller Press CLEAR DATA. Then press UNINSTALL.
Delete everything from the download directory on your SDcard
Force Stop every process you can without making the system unusable in Settings -> Applications -> Running (tab)
Install the update.

I just tried this and it still did not work. What the hell? Why is installing Swype so damn difficult? Just give us an APK or put it in the Market already. It is very frustrating being forced to use this ridiculous process to install and being given the runaround about making it work.

I used to love Swype, now I just wonder if it is worth the hassle!

jkrell
09-12-2010, 6:17 PM
OK, people -- simple fix for this from a user in another thread. When you install Swype (after the installer downloads it, etc.), instead of clicking the "DONE" button, hit the back button and voila -- you will be Swyping in no time. It seems there's some kind of bug that is triggered only when you hit "DONE" and if you never do you are good to go!

gotwillk
09-12-2010, 7:13 PM
OK, people -- simple fix for this from a user in another thread. When you install Swype (after the installer downloads it, etc.), instead of clicking the "DONE" button, hit the back button and voila -- you will be Swyping in no time. It seems there's some kind of bug that is triggered only when you hit "DONE" and if you never do you are good to go!

awesome! this fixed it for me. works perfect now. thanks!!

jjkoztec
09-12-2010, 7:15 PM
Just installed and registered Swype. Didn't do anything different; downloaded the installer, opened it after it installed, logged in and everything ran as it should.

Brian_hanson
09-12-2010, 9:25 PM
Title says it all. Staying with my version until this is all CLEARLY ironed out.

007jerroed700
09-12-2010, 9:43 PM
no problems here. everything went smooth...rooted droid 1, 1.2 ghz, custom rom

swschultz
09-13-2010, 11:27 AM
Just tried again after trying many times two days ago. I reinstalled the installer, and was able for the first time to download the new app. I took a chance and tried to open it upon completion of its installation, and received an error saying that another copy was already installed (it was not). It also was not visible in the Apps drawer from the main screen. I clicked on "Manage Applications" in the Settings menu, and found Swype listed under the "all" tab, but not listed under the "Downloaded" tab. I uninstalled just the Swype app, leaving the installer, and ran the installer again. The Swype app downloaded again, and I let it install, but hit the back button as suggested when it completed. Lots of screens flashed by, but I was finally presented with the remainder of the installation procedure, and was able to enable Swype and get up and running again. Finally! The good news is that I no longer had to select Swype as the input method more than once to have it function properly. So far so good.

swschultz
09-13-2010, 11:31 AM
Forgot to mention, non-rooted Droid 1, running Froyo FRG22D OTA update.

FastKatt
09-13-2010, 4:02 PM
OK, people -- simple fix for this from a user in another thread. When you install Swype (after the installer downloads it, etc.), instead of clicking the "DONE" button, hit the back button and voila -- you will be Swyping in no time. It seems there's some kind of bug that is triggered only when you hit "DONE" and if you never do you are good to go!
This didn't help...
I'm still getting the wrong device error...

Tigrisan
09-14-2010, 7:36 AM
I got the email this morning, followed all the instructions (but use Dolphin as my browser and apkInstaller and it worked like a charm. Thank you! Must have my Swype!

lockrocks
09-17-2010, 4:47 PM
Everything was great till I went from Android 2.1 to 2.2 now after download I can not log in to account it says user name or password incorrect and I have reset it with no problems and swipe still will not install

FastKatt
09-18-2010, 9:13 AM
I've uninstalled and reinstalled about 15x!
I can't get the damned thing working still...

I really don't get it

legend320
09-18-2010, 12:37 PM
Here's my issue. So the version I was using has expired. I got the update email and I deleted all cache files for both the installer .apk file and application file, then I uninstalled. When I go to download and install the “Swype-Installer” nothing happens. This happen to me the last time. I checked the size of the installer file and it is about 5kb when it should be about 48.5kb. The last time this happened to me, Swype team had to send the swipe-installer .apk file to me. This is the only thing that worked for me. I am using the Nexus 1 with Froyo OS. Anyone else notice this?

FastKatt
09-18-2010, 4:32 PM
I think I'm on my 20th download of the installer package...
I keeps telling me it's not built for my phone!
HELP!!!

legend320
09-18-2010, 7:28 PM
I think I'm on my 20th download of the installer package...
I keeps telling me it's not built for my phone!
HELP!!!

@FastKatt...Can you email me the .apk file. Let me try what your file and see if it works for me. seanmu2001@yahoo.com
thanks.

FastKatt
09-18-2010, 8:19 PM
@FastKatt...Can you email me the .apk file. Let me try what your file and see if it works for me. seanmu2001@yahoo.com
thanks.
It won't work without a username and password for the beta
That's why they set-up the install this way...
And no, I won't give out my username and password so you can test it for me, sorry...

legend320
09-18-2010, 9:11 PM
It won't work without a username and password for the beta
That's why they set-up the install this way...
And no, I won't give out my username and password so you can test it for me, sorry...

i know you need a username and pw. I have my own valid username. For some reason I am unable to download the whole file. Since your able to download the file successfully but unable to install, I wanted to do my own troubleshooting. I understand if your not comfortable with this, but if you don't mind I really appreciate it. Thanks

selders59
09-19-2010, 6:07 AM
Get message Swype expired, logged into swype for new upgrade and nothing, no link for upgrade and no email with upgrade.

FastKatt
09-24-2010, 11:40 AM
My problem is fixed!
It was my ROM!!!
I switched from SS 4.7 to SS 4.8 & my 1st try on the install worked!

Maybe this will help someone else?

FastKatt
11-04-2010, 5:05 AM
Well, I've since updated my ROM from 4.8 to 4.9
Now, Swype stops working & I go to reinstall the app...
Now I'm getting the same messages all over again!
HELP!!!

rob.boehm
11-05-2010, 9:44 PM
Well, I've since updated my ROM from 4.8 to 4.9
Now, Swype stops working & I go to reinstall the app...
Now I'm getting the same messages all over again!
HELP!!!

I know there was a change a week or so ago that prevents Swype from installing on any phone that has the production version pre-installed on it. (Disaster can be caused if it is installed) I'm checking on it right now, but it's possible that we could be mis-identifying your ROM as a production OEM that has swype pre-installed.

What's the exact error message that's being thrown, and this is for Simply Stunning ROM too right?

brian.resnik
11-05-2010, 11:21 PM
I know there was a change a week or so ago that prevents Swype from installing on any phone that has the production version pre-installed on it. (Disaster can be caused if it is installed) I'm checking on it right now, but it's possible that we could be mis-identifying your ROM as a production OEM that has swype pre-installed.

Sorry, Rob, but I was misinformed when I told you that tidbit, heh. The error in question (the one we didn't recognize) was actually a custom Android error from Samsung, not something being thrown by our installer. Sorry for the confusion. Carry on :D

FastKatt
11-06-2010, 7:34 AM
Yes it's Simply Stunning
The error is:
The Swype package you installed is configured for another device and will operate with limited functionality. Please contact Swype about this issue.

It types, but doesn't Swype...

FastKatt
11-06-2010, 7:16 PM
Tried this today:


Okay, now my Swype isn't working...
I can type on it not it's not accepting the swiping actions...

edit the build.prop file to read ro.build.id=FRG22D not FRG83. Then reboot.

edit: You will have to change this if you install any of chevy's tool updates also because i had to do it again after i installed his latest patches. This will work on other roms too if you run into the problem again. (Don't thank me for the solution, I found it on another ROMs section.)
It didn't work either...
Is there something you could add to this to make it work?
Is there maybe a way to make it more forgiving in the install???

rob.boehm
11-06-2010, 8:41 PM
Yes it's Simply Stunning
The error is:
The Swype package you installed is configured for another device and will operate with limited functionality. Please contact Swype about this issue.

It types, but doesn't Swype...

Yeah, this comes up from time to time. Especially on multiple reinstalls. Follow the instructions here for resolution: http://forum.swype.com/showthread.php?993-KNOWN-BETA-for-Android-ISSUES-Please-read-before-posting-(UPDATE-9-23-10)

Essentially you have to delete everything Swype from your phone and reinstall. I ran into it earlier while testing on my G1 today; even had to reboot after clearing it all out before I got it to work :/

FastKatt
11-07-2010, 7:36 AM
1. Make sure Swype and SwypeInstaller are both INSTALLED (even if showing errors when trying to use)
2. Go to Settings -> Language & Keyboard and UNCHECK Swype.
3. Go to Settings -> Applications -> Swype Press CLEAR DATA. Then press UNINSTALL.
4. Go to Settings -> Applications -> SwypeInstaller Press CLEAR DATA. Then press UNINSTALL.
5. Delete everything from the download directory on your SDcard
6. Download, install, and configure the application SWAPPER2 from the Android Market (it's free!)
7. Reboot your device.
8. Force Stop any non-system background tasks running in Settings -> Applications -> Running (tab)
9. Install the update.
Short of the Swapper2 App, this is what I've been doing the whole time...
2 issues with the Swapper2 App:
1. There is no instruction to what you are installing the app to do.
2. The app itself, in the Android Market Info, states it will likely degrade the SD Card of the phone it is installed to...
So, what does installing the Swapper2 App do for me? Got any tips? I'm at a loss at this point...

FastKatt
11-07-2010, 7:54 AM
Does it matter that the APK is installing to the SD Card?
Also, the installer is installing to the SD Card...
I tried to move the installer, but I don't have room in the phone to move it.

Where are the developers? They should be in on this... This sounds like the prime reason to have a Beta. Let's get this solved!

brian.resnik
11-07-2010, 7:57 AM
FastKatt:

Swapper2 creates a file on your SDcard which the system uses as "virtual memory." The idea is that if you're running low on RAM, you can use a "swap file" to give the system more - albeit much slower - memory to work with, to keep applications open that it would otherwise have to close. Using a swap file on your SDcard will wear it out because swap files do a lot of reads/writes, and SDcards - and any other solid state drive - can only perform so many reads/writes before they die.

The upshot here is that we only need swapper2 installed during the actual installation. Once Swype is installed correctly, you can remove swapper2. The actual impact on the life of your SDcard will be very very small. That warning is more meant for people who use a swap file all the time, thus putting a lot of extra strain on their SDcard.